Installing pfsense in vm: can ping devices, cannot connect to internet



  • First, here's a picture of what I'm trying to do:

    From the guest Ubuntu machines, I can get on the pfsense settings page.  From the pfsense box, I can ping the host machine.  For some reason, I cannot get on the internet from the ubuntu boxes.  Any help?

    http://imgur.com/a/v2cGE

    I included relevant screen grabs in the above link.

    Any help would be much appreciated.  If you want more screen grabs, let me know.


  • Netgate Administrator

    You have a conflict between your subnets.
    Your LAN and OPT1 IPs are in the WAN subnet which will have broken routing unless you are using a fully routed configuration.
    Also you in the last screenshot you have a OPTGW which you shouldn't if it's not a WAN connection.
    What are you using OPT1 for?

    Steve


  • Rebel Alliance Global Moderator

    Yeah your mask on your wan interface is so large it includes the networks on your lan and opt1 interfaces.

    with that /21 you have on the wan 255.255.248 your network is 10.1.0.1 - 10.1.7.254, which your other interfaces are also on.  Not a valid setup.

    I would also ask how your connecting your wan interface to your host real world interface? is this bridged or natted?  Bridge is better option if you ask me.  Then your lan and opt1 if you need it can just be host only network.  Not tied to real physical interface.

    I run my pfsense on esxi with a lot of other vms and also it filters and is gateway for my real physical network.

    Your questions about running pfsense in vm might be better suited for the vm section though.



  • I solved it so I figured I'd post my solution and mistakes:

    I was using opt1 for the connection from pfsense to the two linux boxes.  LAN wasn't really doing anything and the pfsense vm had 3 vNetwork Adapters.  I removed one of them from the pfsense box so the WAN was bridged and the second network adapter was connected to vnet2.  I also moved the lan to 10.1.1.x/24.

    This got everything working as far as I can tell.  Now I'm just playing around with squidguard.


Locked