No natting for subnet that is not directly connected.

  • I have a multi-wan setup with pfSense 2.0.1.  For some reason, it doesn't seem to be natting traffic from subnet that is not directly connected to the pfSense box.

    <adsl routers="" (10.0.0.x="" vlans)="">- <pfsense>- < network> - <router>-< network>

    From the network I can ping the LAN side of the pfSense box (, but cannot ping the WAN side (, or the ADSL router (, or any global addresses.  From the network I have no problems pinging any of these.

    I have verified through the firewall logs that it is passing traffic from the network, so it doesn't seem to be a firewall issue.

    I also tried switching to manual NAT, and noticed that all of the automatically generated NAT rules were only for the network, so I manually added rules for the network, but that didn't seem to work either.</router></pfsense></adsl>

  • if you ping from adsl .4 subnet does it get to internet?
    you could add route to adsl, that is behind pfsense

  • Sorry, it was a bad ACL on the other router that was causing the problems. 
    Problem has been solved.  Thanks.

Log in to reply