Siproxd on 2.1



  • Seem to have lost siproxd functionality with the latest update (i386) (built on Thu Jun 28 20:00:36 EDT 2012
    FreeBSD 8.3-RELEASE-p3)

    Getting this in systemlog:
    Sipproxd is installed but not started. Not installing redirect rules.
    But it does apear to be running:
    nobody  744  0.0  0.3  9052  6108  ??  S    9:47PM  0:00.22 /usr/pbi/siproxd

    Siproxd not seeing anything:
    21:47:19 INFO:log.c:195 Accepted DEBUG TCP connection [fd=12], debugpattern=-1
    21:47:19 INFO:log.c:196 siproxd-0.8.0-5472 i386-portbld-freebsd8.1
    21:47:19 sock.c:157 entered sipsock_waitfordata
    21:47:24 register.c:509 sip_agemap, t=1341002844
    21:47:24 register.c:139 saving registration table
    21:47:24 sock.c:157 entered sipsock_waitfordata
    21:47:29 register.c:509 sip_agemap, t=1341002849
    21:47:29 sock.c:157 entered sipsock_waitfordata
    21:47:34 register.c:509 sip_agemap, t=1341002854
    21:47:34 sock.c:157 entered sipsock_waitfordata
    21:47:39 register.c:509 sip_agemap, t=1341002859
    21:47:39 register.c:139 saving registration table
    21:47:39 sock.c:157 entered sipsock_waitfordata
    21:47:44 register.c:509 sip_agemap, t=1341002864
    21:47:44 sock.c:157 entered sipsock_waitfordata
    21:47:49 register.c:509 sip_agemap, t=1341002869
    21:47:49 sock.c:157 entered sipsock_waitfordata

    Will test it again next build.



  • no change in built on this build, still not working: Fri Jun 29 19:27:16 EDT 2012 FreeBSD 8.3-RELEASE-p3



  • @Roots0:

    no change in built on this build, still not working: Fri Jun 29 19:27:16 EDT 2012 FreeBSD 8.3-RELEASE-p3

    You can check here if something has changed on your package.
    https://github.com/bsdperimeter/pfsense-packages/commits/master
    If noone is committing any fix it will probably not work automatically in future.



  • Thanks, hopefully the creator or someone with more knowledge than me can have a look at it.



  • @Roots0:

    Thanks, hopefully the creator or someone with more knowledge than me can have a look at it.

    Rename the attached file to siproxd.inc
    Go to DIAGNOSTICS -> Command Prompt -> Upload
    Go to DIAGNOSTICS -> Command Prompt -> Execute shell command

    mv /tmp/siproxd.inc /usr/local/pkg/
    

    Go to SERVICES -> siproxd -> Settings -> Click Save
    Go to SERVICES -> siproxd -> Users -> Click Save
    Check syslog if something changed but best would be to restart the system and then check if everything is working.

    siproxd.inc.txt



  • It appeared not to be working until I disabled the following in SIPDefault.cnf
    nat_received_processing: 0
    nat_enable: 0

    Bluddy Cisco totally not user friendly!

    Anyway tyvm  Nachtfalke.



  • @Roots0:

    It appeared not to be working until I disabled the following in SIPDefault.cnf
    nat_received_processing: 0
    nat_enable: 0

    Bluddy Cisco totally not user friendly!

    Anyway tyvm  Nachtfalke.

    Is this working with the new or "old" siproxd.inc ?



  • The new version of siproxd.inc



  • @Roots0:

    The new version of siproxd.inc

    And the old one did not on pfsense 2.1 ?
    I just want to make sure to post a commit on github if it is needed.

    Thank you!



  • Old version is not working for me. Thanks.


Locked