[SOLVED] Does /boot/loader.conf.local work for you ?



  • Apparently it doesn't work on my 2.1-BETA0 … (any settings there seem to be ignored)

    Setup seems OK:

    grep ^loader_conf_files /boot/defaults/loader.conf
    loader_conf_files="/boot/device.hints /boot/loader.conf /boot/loader.conf.local"


  • Rebel Alliance Developer Netgate

    Yes, I've set things there and they're respected.

    What are you trying to set that is "ignored" there?

    Sure there isn't a syntax causing the file to be invalid?



  • Hi jimp,

    I've tried various settings, e.g. ecn:

    cat /boot/loader.conf.local
    net.inet.tcp.ecn.enable="1"

    sysctl -a|fgrep ecn
    vfs.bufreusecnt: 1326
    net.inet.tcp.ecn.maxretries: 1
    net.inet.tcp.ecn.enable: 0
    net.inet.sctp.use_dcccecn: 1
    net.inet.sctp.ecn_enable: 1
    net.inet.ipsec.ecn: 0
    net.inet6.ipsec6.ecn: 0

    Whereas when I set them from CLI instead, it always works. Btw user miles267 seemed to have a similar problem, check http://forum.pfsense.org/index.php/topic,50484.0.html

    I've checked dmesg for any errors in parsing loader.conf.local, but I couldn't find any.

    I'll probably do a new 2.1-BETA install from scratch and try again.


  • Rebel Alliance Developer Netgate

    If it's not a loader tunable you may not be able to set it there. If you can set it run-time, just add it to System > Admin on the Tunables tab.



  • This worked, thanks for the tip!


Locked