Need help with RDP issue



  • Hi everyone,

    I have an issue I need some help with thats been driving me mad, its a long shot but I'm hoping maybe at least one other person has either seen / had the same issue or is clever than me (not difficult) and can suggest a resolution.

    I have done a fair bit of research trying to fix this so I will try and be brief and list the main points.

    I have an ESXi Host as the only host in a Vsphere 5 environment.
    The ESXi host is a HP ML110 G6
    It has one Physical NIC

    I have set up 2 Vswitches one which is bound to the physical NIC (vswitch0) and the other isnt bound to any NIC (vswitch1)

    I have Windows Server 2008 Virtual Machines some are on Vswitch0 and some are on Vswitch1.  This is to simulate a different physical network segment.

    I did have a pfsense router device with a NIC on each vswitch to route traffic between the different network segments.

    Its the latest build of pfsense.

    It DOES ROUTE traffic successfully.  I can ping all hosts from all subnets

    My laptop is on the same network segment that vswitch0 (physical NIC on ESX Host) and I can be pinged and can ping all hosts as well.

    BUT when I try to RDP to any host on the remote subnet, RDP connects… I get anywhere between 2 - 30 seconds of successful RDP session then the session locks and the screen goes blank.

    I know its not a firewall issue as I have had a) and allow all rule on and b) have also tried with all packet filtering turned off (routing only)

    I have tried from different laptops.

    I can successfully RDP to the Servers on the WAN side of PFSense (the same network segment that my laptop is on)

    SO something is going wrong with RDP traffic through pfsense.

    In the event log of the Machines that I try to RDP to there are Errors from TermServ Error 55 (or 56 I think)  Error detected in protocol stream and the remote client has been disconnected (then the IP address of my laptop)

    I have rebuilt the pfsense router from scratch.

    I am at my witts end... has anyone got any suggestions?

    THank you

    Patrick



  • If you're familiar with packet traces, I'd try loading up Wireshark on either the laptop (probably best case) or a server that you're connecting to and see what that tells you.


Locked