External access to internal www server - very slow



  • Hello
    I have problem to access from external to my web page on internal LAN. Everthing is set up correct at my point of view.
    Connection to my web is horrible slow, my page can not load or only load a fragment. Speed is on bytes !!
    My router is on pfSense of cource, and my DSL is 10 - 20 % used.
    So I can't understand why it is that. What wrong with the shaper ?



  • That is what i call a frustration post.
    The only thing that tells anything about your installation is shaper.



  • Hello
    I'm not frustrated. I don't know how to resolve this problem.
    I'm not sure which queues depending data transfer from router and to router (from WAN), qwandef/qlandef ?

    my config of shaper:
    altq on fxp0 hfsc bandwidth 460Kb queue { qwanRoot }
    altq on fxp1 hfsc bandwidth 3680Kb queue { qlanRoot }

    queue qwanRoot bandwidth 460Kb priority 0 hfsc { qwandef, qwanacks, qVOIPUp, qGamesUp, qAdmin_Up, qOtherH_Up, qOtherL_Up, qP2PUp }
    queue qlanRoot bandwidth 3680Kb priority 0 hfsc { qlandef, qlanacks, qVOIPDown, qGamesDown, qAdmin_Down, qOtherH_Down, qOtherL_Down, qP2PDown }
    queue qwandef bandwidth 5% priority 3 hfsc (  default realtime 1% )
    queue qlandef bandwidth 28% priority 3 hfsc (  default realtime 1% )
    queue qwanacks bandwidth 36% priority 7 hfsc (  realtime(40% 3 36%) )
    queue qlanacks bandwidth 2% priority 7 hfsc (  realtime(5% 3 2%) )
    queue qVOIPUp bandwidth 16% priority 6 hfsc (  upperlimit 256Kb realtime(32% 8 16%) )
    queue qVOIPDown bandwidth 2% priority 6 hfsc (  upperlimit 640Kb realtime(4% 8 2%) )
    queue qGamesUp bandwidth 23% priority 6 hfsc (  realtime 1Kb )
    queue qGamesDown bandwidth 3% priority 6 hfsc (  realtime 1Kb )
    queue qAdmin_Up bandwidth 1% priority 5 hfsc (  upperlimit 96Kb realtime 2Kb )
    queue qAdmin_Down bandwidth 10% priority 5 hfsc (  realtime 2Kb )
    queue qOtherH_Up bandwidth 17% priority 4 hfsc (  red ecn upperlimit 320Kb realtime(2% 3 1Kb) )
    queue qOtherH_Down bandwidth 50% priority 4 hfsc (  red ecn linkshare 30% realtime(2% 3 1Kb) )
    queue qOtherL_Up bandwidth 1% priority 2 hfsc (  red ecn upperlimit 256Kb linkshare 1% realtime 1Kb )
    queue qOtherL_Down bandwidth 4% priority 2 hfsc (  red ecn linkshare(4% 1000 4%) realtime 1Kb )
    queue qP2PUp bandwidth 1% priority 1 hfsc (  upperlimit 120Kb realtime 1Kb )
    queue qP2PDown bandwidth 1% priority 1 hfsc (  upperlimit 1280Kb realtime 1Kb )



  • @MPP:

    Hello
    I'm not frustrated. I don't know how to resolve this problem.

    You appear frustrated as you posted no information to help diagnose your problem.  Nothing about the version of PFSense you're using, what hardware you've got, the bandwidth of your connection or even whether or not the problem exists if you bypass your PFSense box/disable traffic shaping.



  • OK. my english is not well.

    My software/hardware configuration:
    pfSense 1.1, P3 733MHz, 256MB RAM + two Intel's NIC and DSL 4096 (see in the shaper).
    I'm sure that is not a hardware problem.
    This problem doesn't exist with my web server only but every PCs on internal (LAN) whitch I want to connect from WAN.

    Thanks
    Martin



  • Ok, simple question:

    If you disable the shaper, does the problem go away?

    I'm also confused, you first said "I have problem to access from external to my web page on internal LAN", now you're saying "This problem doesn't exist with my web server but every PCs on internal (LAN) whitch I want to connect".  Which is it?  Is the problem that connections to your (internal) web server from the Internet are slow, or is it that connections from your Internal PCs to the Internet is slow, or is it something else?



  • I'm sure he means from the outside WAN to the web server.  Stop hassling the guy, you can only do so much with Google translator  ;D  I'll agree with your advice though, if you disable the shaper, you may see the problem disappear, let us know.  Also let us know what port you have your web server on.



  • calm down :)
    It's very difficult to check if it's work cause the upload rises up to the maximum value and its make the connection  impossible.
    There is unable to connect with the www server and the other PC's, I wish to menage via www or telnet or ssh.
    CP is set to pass LAN IP from/to, and queues in traffic shaper expecially for connection, all without effect, still very very slow access.

    Martin



  • You should try upgrading
    http://pfsense.basis06.com/download//updates/pfSense-Full-Update-1.2-BETA-1.tgz

    if you disable the shaper, you may see the problem disappear, let us know.

    Any memory or CPU bottleneck ?

    Where do you live, maybe you can get some local language support.


Log in to reply