FREEBSD 8.1 + RELENG_2_0 build problem with perl5.14



  • I am trying to build the ISO for 2.0-RELEASE on FreeBSD 8.1 running on virtualbox. I have followed instructions mentioned at http://devwiki.pfsense.org/DevelopersBootStrapAndDevIso/ skipping the steps for Jail setup (0a - 2d).

    Following is my pfsense-build.conf

    
    # set_version.sh generated defaults
    export PFSENSE_VERSION=2.0-RELEASE
    export FREEBSD_VERSION=8
    export FREEBSD_BRANCH=RELENG_8_1
    export PFSENSETAG=RELENG_2_0
    export PFSPATCHFILE=/usr/pfsense/tools/builder_scripts/../builder_scripts/patches.RELENG_8_1
    export PFSPATCHDIR=/usr/pfsense/tools/builder_scripts/../patches/RELENG_8_1
    export SUPFILE=/usr/pfsense/tools/builder_scripts/../builder_scripts/RELENG_8_1-supfile
    export CUSTOM_COPY_LIST=/usr/pfsense/tools/builder_scripts/../builder_scripts/copy.list.RELENG_8_0
    # Comment out the following line if you would like to automatically select an update server.
    export OVERRIDE_FREEBSD_CVSUP_HOST=cvsup12.freebsd.org
    export BASE_DIR=/usr/pfsense/tools/builder_scripts/../..
    export BUILDER_TOOLS=/usr/pfsense/tools/builder_scripts/..
    export BUILDER_SCRIPTS=/usr/pfsense/tools/builder_scripts
    export EXTRA_DEVICES=siba_bwn,bwn,run
    export PFSPORTSFILE=buildports.RELENG_2_0
    #export PFSENSE_WITH_FULL_GIT_CHECKOUT="true"
    
    

    The error being reported is while building port for perl5.14. It complains that perl5.10 is already installed

    
    Script started on Tue Jul  3 18:00:33 2012
    ===>  Cleaning for perl-5.14.2_2
    
    ===>  perl-5.14.2_2 conflicts with installed package(s): 
          perl-5.10.1_1
    
          They install files into the same place.
          You may want to stop build with Ctrl + C.
    ===>  License ART10 GPLv1 accepted by the user
    
    ===>  perl-5.14.2_2 conflicts with installed package(s): 
          perl-5.10.1_1
    
          They will not build together.
          Please remove them first with pkg_delete(1).
    *** Error code 1
    
    Stop in /usr/ports/lang/perl5.14.
    
    Script done on Tue Jul  3 18:00:46 2012
    
    

    perl5.10 was installed as dependency for git. Any pointers would be much appreciated.

    A lot of packages are dependent on perl5.14 including autoconf, libidn, php52-* etc. whose builds are being failed due to dependency on perl5.14.



  • remove git,perl 5.10, then install a newer perl before re installing  git



  • Thanks marcelloc.

    It is building and I am waiting for it to finish. No complaints about Perl till now  :)



  • Thanks for the help Marcello. It built successfully.

    But I was looking forward to 2.0.1-RELEASE while what it produced was 2.1-RC. What version do I need to choose to build 2.0.1-RELEASE?



  • export PFSENSE_VERSION=2.0-RELEASE
    export FREEBSD_VERSION=8
    export FREEBSD_BRANCH=RELENG_8_1
    export PFSENSETAG=RELENG_2_0

    It looks like your config is set to build RELENG_2_0 instead of MASTER(2.1) branch.  ???


  • Rebel Alliance Developer Netgate

    RELENG_2_0 is currently 2.0.2-RC3, not 2.1.

    If you want 2.0.1 exactly you need to build from the tag RELENG_2_0_1

    You're better off on 2.0.2 though.


Log in to reply