HAVP new install - am I missing something?



  • Just wiped my virtual pfSense install to try and sort this as I'm confused. I had HAVP working in 2.1 Beta before, but have just gone back to 2.0.1 in my lab as that's what I use in production.

    So, HAVP isn't working.

    On bootup the pfsense box says
    'Starting package HAVP antivirus…pw: unknown group havp' done.'

    In the webgui the antivirus server says (Started), but the status says stopped. The HTTP Antivirus proxy starts but then stops again. The AV engine say it's already up to date when I try to update, but it does that within the same second of starting the update. The Base info for the AV database, date, size, ver etc is all missing, so I can only conclude it can't download updates. I've tried changes it's Dat file source but it's still not working.

    Proxy set to transparent mode.

    Logging on.

    Does anyone have any ideas?

    Thanks!

    Simon



  • Well, it's now been confirmed by the boss, who also has tried on his pfsense install.

    It seems like the package is now broken when installed. Who is the developer?



  • Configure havp
    Update AV base
    Start havp.



  • Hi there,

    Yup, tried this. The AV base just isn't downloading for some reason. The base info in the general page of the antivirus package settings remain blank, whether I try the update with the AV enabled or disabled….



  • @S_D:

    Hi there,
    Yup, tried this. The AV base just isn't downloading for some reason.

    AV Bases must be updated. In their absence, you do not start the AV server.



  • Well, last night's ClamAV update means that it now works in 2.1 Beta…



  • A bit more sense on this.

    On 2.0.1, running 'freshclam' (update the AV base) from Shell results in a couple of 'permission denied' errors on /var/db/clamav/ and /tmp so 'chmod 777' on those two directories and now it works!

    Weird. Clearly something's changed in the package…


  • Rebel Alliance Developer Netgate

    Reinstall the pkg and try it again.



  • Nope doesn't work at all now, and the freshclam command has disappeared.

    I'll try rebuilding the box from scratch and trying again…


  • Rebel Alliance Developer Netgate

    Hit the "X" to remove the package, then install it again, rather than using the 'pkg' button.

    Or to be more thorough:
    1. Hit the X to delete the pkg
    2. From the shell: pkg_delete -f havp* clamav*
    3. Reinstall the pkg from the GUI



  • OK, well unfortunately I had blown away the firewall before you posted your message, but on a new install at least it works now, so whatever has been done has fixed it. :)

    Thanks



  • @jimp:

    Reinstall the pkg and try it again.

    In the latest package there is a problem with the database specified for the "US" as it points to the wrong domain, I am not even sure where this came from. This is causing errors in the updates of the database.

    /usr/local/pkg/havp.inc

    line 889 case 'us': $conf[] = "DatabaseMirror clamav.catt.com"; break;        # united states

    The line should be:

    line 889 case 'us': $conf[] = "DatabaseMirror db.us.clamav.net"; break;        # united states



  • You can enter self update source in web form.


  • Rebel Alliance Developer Netgate


Log in to reply