Proxy Server on 2 Subnets

  • Hi.

    I currently have 2 different subnets running from 1 pfsense dedicated box at the moment.

    One subnet is and the other

    Currently only subnet is proxied and is filtered accordingly.

    Can i proxy both of these on the same squid proxy serve instance?

    I know currently the proxy allows on 1 subnet at a time to be subnetted.

    Is there anyway to do this or would i need to go virtual with my pfsense?

    Help, tips and advise would be greatly appreciated.

  • In the selection screen of squid, you can listen on multiple NICs by using the CTRL to select the ones you want to listen on. Are you doing a transparent proxy?

  • Yes, just select the interfaces on which squid should listen. No matter if it it is one or two interfaces. My squid is listening on 7 interfaces.
    And if you do not want to proxy BETWEEN the two subnets you can enter these subnets in squid GUI and then this traffic will not be proxied.

  • Ok so it is possible?

    Only network that is proxied at the moment has a port specified so it is not transparently proxied.

    How would the time restrictions etc work then?

    Would they be applied to both networks or would i need to specify rules for both networks?

    I tried to proxy the second network with the control button and it network doesn't seem to be work throu the proxy then.

    My nextwork selection box looks like this:

    The network is proxy port is set to: 3128

    A user can still access the internet if they do not specify the proxy settings. Which is weird.

    Any suggestions on what i missed?

  • When you are using a non-transparent proxy then you need to specify the proxy in the browser with port 3128.
    Then the traffic - based on the brwoser - will pass the proxy. If no proxy is specified, then it will bypass the proxy and they will have free access. To prevent this, you need to block port 443 (https) and port 80 (http) so that they cannot bypass the proxy.

    All other traffic than 443 and 80 will not be handeled by squid so you need to use firewall rules.

  • Great stuff. I remember that now. Sorry i was being completely blond.


    Thanks a mill

Log in to reply