Time in system log bug



  • The time in my firewall logs are incorrect.

    NTP is synced. Timezone set to Europe/Amsterdam. When using the command time on shell it DOES show the correct time.

    Guess this bug hasn't been fixed yet. Found an old topic with the same problem:

    http://forum.pfsense.org/index.php/topic,15028.0.html


  • Netgate Administrator

    There was a post about this a while ago.
    The timezone in the system log is set when syslogd was started, at boot. If you have changed the timezone since then it will be incorrect untill you reboot (or restart syslogd I guess).

    Steve

    Edit: Can't find that post now.  :-\



  • I have already rebooted.. no luck :(



  • I am using the same timezone and I do not have any problems on pfsense 2.0.0 and 2.0.1.

    As stephenw10 said, when changing the timezone on GUI - the time is not changen everywhere on system until a pfsense reboot.

    Try to check, if the ntp server is up and reachable from pfsense. Perhaps try to change the setting to another timezone, reboot, change back to your timezone, reboot and try again.



  • After changing the timezone to something else and then setting it back to Europe/Amsterdam + reboot it has been solved. Wonder why it didn't work the first time.

    Thanks for the solution though!


Locked