Wifi para lan



  • Estou com problemas para acessar a LAN a partir da wifi, adicionei a regra para liberar todo o trafego de any para any e mesmo assim siquer pinga um pc na lan Estranho que o contrário funciona, da LAN para WIFI consigo pingar um notebook e até mesmo acessar as pastas compartilhadas. Alguem já passou por isso?



  • Você está usando roteador como wifi? Está usando uma placa wifi instalada no pfSense? Especifique melhor como está sua rede.



  • Ok, estou usando uma placa pci wifi no PFSENSE e nas configurações da wifi está como Access Point.



  • @zimolong:

    Ok, estou usando uma placa pci wifi no PFSENSE e nas configurações da wifi está como Access Point.

    Ainda faltam informações…
    Você deve ter 3 interfaces de rede: WAN, LAN e OPT1, ou seja lá os nomes que você deu a cada uma destas interfaces.
    Em qual destas interfaces você criou a regra de any para any?
    Será que você poderia tirar uma print screen da interface de rede wifi e postar aqui?



  • Certo, as regras da LAN são as default. A regra any para any esta na interface WIFI. Tenho 3 interfaces uma WAN(PPPOE), LAN e WIFI. Eis as imagens. Grato.






  • A interface WIFI está na mesma subrede da interface LAN?



  • O endereço da LAN é 10.47.35.0/24 e wifi é 192.168.2.1/24. Me dá a impressão que tem algo a ver com rota!! Muito estranho haver comunicação da LAN para wifi mas o contrário siquer pinga.



  • zimolong,

    Você realmente precisa que as interfaces WIFI e LAN estejam em redes diferentes? Se sim, por quê? E também: Você notou quantas perguntas eu tive que fazer, até agora? Se você tivesse colocado um mínimo de informações sobre sua rede, talvez seu problema já teria sido resolvido.

    Regras Básicas para Utilização do Fórum:.
    5. Procure sempre fornecer um mínimo de informações possível que sejam relevantes ao seu problema.  Perguntas como “Não consigo instalar o pfSense. Alguém me ajuda?” muitas vezes são ignoradas pois demandam perguntas sobre informações que já deveriam ter sido antecipadas.

    Seja mais específico que, tenho certeza, você terá a ajuda necessária.  :)



  • Exemplificando o que o Johnnybe disse…

    Você precisa fornecer mais informações, por exemplo, se as duas interfaces precisam se comunicar, porque precisam estar em redes diferentes?
    Como estão suas regras de Firewall?
    Por que não fazer uma Brigde entre as duas interfaces?

    Explique com mais detalhes para que possamos lhe ajudar...



  • Correto, desculpe a minha ignorância quanto a falta de dados. Então vou tentar passar qual é o meu objetivo quanto ao firewall.
    Na interface wifi coloquei em rede diferente da LAN porque é somente para manutenção (uso dos adminstradores dentro do CPD) e para tanto não quero
    o uso do proxy e nem controle de velocidade (nessa parte está funcionando) quando conecto um notebook via wifi faço atualizações e navego normalmente. Porém pode acontecer deu precisar acessar algumas pastas compartilhadas no servidor de dados que está LAN (isso não consigo).
    Outra situação é que a faixa de IP fornecida pelo ESTADO está escassa, porisso separando o wifi da lan não precisarei reservar ip para o CPD.
    Estou usando tambem a VPN PPTP e a situação é pior que a wifi pois siquer navega

    WAN  conexão PPPOE com provedor (IP fixo)
    LAN 10.47.35.0/24 fornecido pela CELEPAR
    WIFI 192.168.2.1/24 para uso dos administradores (sem restrição)
    PPTP 192.168.3.1/16 para uso dos administradores



  • @zimolong:

    normalmente. Porém pode acontecer deu precisar acessar algumas pastas compartilhadas no servidor de dados que está LAN (isso não consigo).

    Desabilite o nat entre as redes(firewall -> nat -> outbound), netbios é um dos piores protocolos para se passar atraves de nat.

    @zimolong:

    Estou usando tambem a VPN PPTP e a situação é pior que a wifi pois siquer navega

    Veja no cliente que estabeleceu a vpn que é o gateway e se você criou regras para permitir este acesso.

    Use o tcpdump na console/ssh para debugar o que está errado ou faltando.

    att,
    Marcello Coutinho



  • No cliente VPN não está definido o gateway e nas configurações do pfsense, a princípio, não tem como definir isso. Agora sobre o NAT entre as redes parece ser esse mesmo o problema, porem tenho que estudar melhor essa opção para não cometer erros.



  • Esta cada vez pior, mudei na interface wifi o tipo de rede de ACCESS POINT para INFRASTRUTURE (BSS) ai danou-se tudo, o pc reiniciou na hora e antes de chegar ao menu principal indica um erro que nem da tempo de ler e reinicia novamente e fica no loop. >:( >:( >:( >:( >:( >:(



  • Você tem backup da configuração antes de alterar?

    Se não tem, vai precisar de um procedimento avançado de dar boot pelo cd, mapear o disco local e desfazer a alteração / restaurar um arquivo de autobackup.

    Segue post de referência (inclusive seu :))
    http://forum.pfsense.org/index.php/topic,51434.msg274984.html#msg274984

    Nuca deixe de fazer um backup do pfsense antes de qualquer alteração. O procedimento de recuperação é rápido e eficiente com os arquivos de backup.


Locked