How I got native ipv6 working with Get.no (a Norwegian ISP)



  • Hey all,

    I was pretty happy when I heard Get.no allows their users to have native IPv6. So I tried to set it up on my ALIX box with pfsense and it was a big mess. I couldn't get anything to work.  In the end it was actually pretty simple….

    I just reflashed my pfsense box with the latest development release of pfsense 2.1. (saved my old copy of config too)

    I then went through the basic wizard and rebooted the pfsense box. Pfsense had already detected IPv6 and setup DHCP6 accordingly. Also it setup the LAN interface to "Track Interface" under the IPv6 configuration.

    The only thing I changed was to adjust the DHCPv6 Delegation Prefix size to /60 under Interfaces-->WAN. And then rebooted and it sprang to life... :))))

    loi-imac:~ loiphin$ ping6 ipv6-test.com
    PING6(56=40+8+8 bytes) 2a02:fe0:cf17:50:c02c:c0e9:725c:b862 --> 2001:41d0:1:d87c::7e57:1
    16 bytes from 2001:41d0:1:d87c::7e57:1, icmp_seq=0 hlim=54 time=49.782 ms
    16 bytes from 2001:41d0:1:d87c::7e57:1, icmp_seq=1 hlim=54 time=50.033 ms

    Yaaaay! Finally on IPv6. I did not re-apply my old config to the pfsense box. I think I will stick with this clean setup and add my old config back where needed manually. I think my pfsense box was messed up in the first place because I had upgraded the 2.0 stable release to 2.1 and used my existing config. By doing a clean install of 2.1, it all worked without any problems.

    So give it a try. Backup your current setup, and then wipe your box clean with a dev 2.1 copy of pfsense.

    loiphin.



  • Good news, thank you for the feedback!



  • BTW, I had to open a ticket with Get.no to have them enable IPv6 on my cable modem in the first place. It is not enabled by default, as I believe they are still beta testing IPv6 for end users.



  • Do you have any details on how the LAN and WAN interfaces, routes, gateways and DHCPDv6/RA look in the GUI?



  • I've got IPv6 enabled from GET as well, but simply doing what you did does not seem to work for me. I can ping 2001:41d0:1:d87c::7e57:1 but sites like http://test-ipv6.com/ is reporting that there is no IPv6 action going on.



  • A am using get as well, and I am considering to upgrade my main FW to 2.1 as well, but in the mean time I have it installed on a test box with tunneling to NetAssist where I get a /48 network and a static ip on WAN.

    With get.no, I've read that you get a /60 prefix, and DHCP allocated IP. With the "Track Interface" setting, are you able to set a /64 network on the LAN side and enable SLAAC? How does that work?

    Thanks


Locked