Lightsquid fails to uninstall



  • I'm preparing to upgrade the pfSense firmware from 1.2.3 to 2.0.1 by first uninstalling all of the packages.
    When I try to remove the lightsquid package I get the following error:

    Warning: main(squid.inc): failed to open stream: No such file or directory in /usr/local/pkg/lightsquid.inc on line 36 Fatal error: main(): Failed opening required 'squid.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/pkg/lightsquid.inc on line 36

    What can I do to resolve this, so I can continue with the upgrade.



  • Install the squid package before LS.



  • Just so I understand…

    I'll need to go back and re-install squid, before I can remove lightsquid?

    I appreciate the help,

    Roger



  • Okay, that did the trick.
    I reinstalled squid. Then I was able to remove lightsquid and finally remove squid.

    Thanks for the help.


Locked