Port Forward and ProxyArp VIP issue



  • So I have a /27 and several servers that need to accessed via public IP (i.e. web servers). I am replacing a failing pfSense running 2.0.1 amd64 with a similar box running the same. On the old machine I had VIPs setup for the public address and setup a port forward to allow web traffic (80 & 443) with rules to match and everything worked just fine. I setup the new pfsense with the exact same config and only some of the PARP/Port Forwards work and some do not (very strange). For the PARPs that didn't work I changed them to Aliases and then they worked. So just to double check I set them back to PARP and no go. Back to to alias, worked fine. Everything is working now but I am worried that I have a bigger problem that will blow up in my face later on down the road and would really like to understand what might be going on to cause this.

    Any help would be greatly appreciated.



  • Could be a residual ARP in the next hop )ISP Router( or the like. I would set it up how you like and restart everything you could. Past that, i would check logs and double check the config.


Locked