[Resolvido] - Duvida sobre o Cache



  • Trabalho com o PFSENSE 2.0, com os pacotes do Squid e Sarg. O Sarg faz geração de 1d.
    Uso 3 Interfaces, sendo 1 pra LAN e 2 WAN onde fiz o FailOver e o LoadBalance.
    A máquina que o PFSense está intalado é um DELL GX620 Pentium 4 com 2GB de memória HD de 80GB

    As configurações do Squid em Cache Mgmt são as seguintes:
    Uso 1024  MB de Hard disk cache size
          64     Memory cache size
          4       Maximum object size
          32     Maximum object size in RAM
          16     Level 1 subdirectories

    Acontece que alguns usuários que usam programas de bancos, não conseguem fazer logon no banco, sempre fala que expirou a sessão deles, mais eles nem chegaram acessar. Acessaram apenas algumas vezes uns dias atrás.

    Quero saber se pode ser o chache que está fazendo isso, se devo limpar o cache? Se sim, como fazer?



  • @kleyverson:

    Quero saber se pode ser o chache que está fazendo isso, se devo limpar o cache? Se sim, como fazer?

    O mais provável é ser configuração no load balance. Bancos(e vários outros sites) criticam a mudança do ip de origem do cliente.

    att,
    Marcello Coutinho



  • é o load balance.. não funciona com bancos..



  • Mais vocês tem alguma dica para eu poder arrumar isso? Ou não tem jeito? Só tirando o Load Balance?



  • @kleyverson:

    Mais vocês tem alguma dica para eu poder arrumar isso? Ou não tem jeito? Só tirando o Load Balance?

    Tem como criar uma regra, para alguns sites passar por apenas um dos links? Uma porta, algo do genero?



  • @kleyverson:

    Tem como criar uma regra, para alguns sites passar por apenas um dos links? Uma porta, algo do genero?

    Bom dia…
    Vc pode criar uma regra geral para todo o protocolo https sair por uma das conexões wan ou criar um alias com todos os ips dos bancos por vc utilizados e aplicar a mesma regra.

    []s



  • Não é necessário criar regras para HTTPS. Vá em System>Advanced>Miscellaneous e marque a opção "Use sticky connections", depois salve e teste.

    Se não funcionar, você tem algum problema com o Squid, tente também colocar os dominio para não fazer Cache.

    Tenho muitos clientes com Load Balance e bancos, receita federal e tudo funciona perfeitamente.



  • LFCavalcanti, fiz os testes agora com o que me sugeriu, funcionou sim. Muitíssimo obrigado.


Log in to reply