DNS forwarding issues in SNAPSHOT-05-14-2007



  • This took me a bit of poking to figure out, but I think I got it.  In SNAPSHOT-05-14-2007, if pfSense's domain is example.local (so the box is pf1.example.local, etc), then DNS queries for anything.example.local fail.  Our internal DNS server hosts three zones, all of which I could lookup except example.local.  If I change the domain in pfSense to another that we host in DNS, then queries to that domain fail, and example.local works.

    My workaround:

    I used fw.example.local as the domain, and all queries worked fine from there.

    I believe this bug was introduced in this snapshot or a very recent one.  I used SNAPSHOT-05-04-2007 previously and had no such DNS issues.

    This bug is not a huge one for me, might it might be good to look into.

    Hope this helps someone!



  • Please try the most recent snapshot.



  • I just tried the most recent snapshot (1.2-BETA-1-TESTING-SNAPSHOT-05-24-2007) and the problem still exists.



  • I think this is just expected behavior for dnsmasq. I recall someone reporting the same thing on m0n0wall.

    If you use the forwarder to forward that domain to the internal DNS servers, it may work around that, not sure.



  • I have the DNS forwarder for the domain enabled as well with no luck.  This did work fine in previous snapshots btw.  No biggie for me, though.  Just wanted to help others out.


Log in to reply