Re0: Watchdog Timeout only when accessing webGUI



  • So heres a weird problem that has kept me on 1.2.3 release for the last few years.

    I have a machine and the onboard nic (LAN) is Re0. When i try and access the web gui, the interface stops responding to pings for aprox 5 - 15 pings. it then bounces back and works fine and normal. The interface works fine and normal, unless i go to the web gui. I unfortunately cannot swap out the onboard card.

    turning off https seems to have helped, but it still does it sometimes. Seems random. but usually when i am clicking around things in the webgui. (for instance dhcp log caused this one).
    Here is an excerpt from system log.

    
    Jul 14 14:43:13 	apinger: Starting Alarm Pinger, apinger(1595)
    Jul 14 14:43:13 	check_reload_status: Reloading filter
    Jul 14 14:43:12 	apinger: Exiting on signal 15.
    Jul 14 14:43:12 	php: : The command '/sbin/ifconfig bridge0 addm re0' returned exit code '1', the output was 'ifconfig: BRDGADD re0: File exists'
    Jul 14 14:43:12 	php: : rc.newwanip: on (IP address: 192.168.1.250) (interface: lan) (real interface: re0).
    Jul 14 14:43:12 	php: : rc.newwanip: Informational is starting re0.
    Jul 14 14:43:07 	check_reload_status: rc.newwanip starting re0
    Jul 14 14:43:07 	php: : Hotplug event detected for lan but ignoring since interface is configured with static IP (192.168.1.250)
    Jul 14 14:43:05 	php: : Hotplug event detected for lan but ignoring since interface is configured with static IP (192.168.1.250)
    Jul 14 14:43:01 	kernel: re0: link state changed to UP
    Jul 14 14:43:01 	check_reload_status: Linkup starting re0
    Jul 14 14:42:59 	check_reload_status: Linkup starting re0
    Jul 14 14:42:59 	kernel: re0: link state changed to DOWN
    Jul 14 14:42:59 	kernel: re0: watchdog timeout
    Jul 14 14:42:55 	sshd[50580]: Timeout, client not responding.
    Jul 14 14:38:45 	sshd[50580]: Accepted keyboard-interactive/pam for root from IPADDRESS port 51657 ssh2
    
    

    What is printed to the console is "re0: watchdog timeout" when the failure occurs.

    machine is Intel(R) Pentium(R) 4 CPU 2.80GHz 1gb ram. p4p800 i believe

    I should also say that the problem did not occur on PFSENSE 1.2.3 which I am doing a upgrade install from. Current version is 2.0.1-RELEASE (i386)

    I can repeatedly make the problem occur by going to PFtop. So its something about heavy usage by the webgui i think… Wereas just watching the graphs on the pfsense dashboard page is fine for hours.

    Anyone heard of anything like this? any tweak I could make the the web gui? its nice to be able to use it!!



  • That's a common issue with some Realtek NICs, kind of surprised you didn't see it on 1.2.3 as that exact issue has been reported by some for ages. Best I can offer would be to try a 2.1 snapshot since that newer FreeBSD base has a newer re driver which I know has fixed a number of issues but no idea on that one in particular.



  • Ended up using a PCI dual nic card (2 interfaces on one card) that i had lying around. I am just going to disable onboard.

    maybe they will fix in 2.0.2 if there is s snapshot. oh well!


Log in to reply