BUG on today's update



  • Current version: 2.1-BETA0
          Built On: Fri Jul 13 19:59:57 EDT 2012
       New version: Sun Jul 15 03:32:17 EDT 2012

    Update source: http://snapshots.pfsense.org/FreeBSD_RELENG_8_3/i386/pfSense_HEAD/.updaters

    –----------

    Downloading complete but sha256 does not match.

    Auto upgrade aborted.

    Downloaded SHA256: 0e1781039d923fc7a95cbaa752c06392f87493b0fa81a33d54482903c7724304

    Needed SHA256:


    BUG is here:
    latest.tgz.sha256
    SHA256 (/tmp/builder**//**updates/latest.tgz) = 0e1781039d923fc7a95cbaa752c06392f87493b0fa81a33d54482903c7724304

    Double hash.

    Also, for some odd reason Snort started to blocking almost everything!  It wasn't like that from last update.



  • @Gradius:

    Also, for some odd reason Snort started to blocking almost everything!  It wasn't like that from last update.

    because its working correctly now… you have to fine tune it for your network.. either don't enable all the rules, or suppress them... search the forum, or check out snort.org



  • New update, still same bug:
    A new version is now available

    Current version: 2.1-BETA0
          Built On: Fri Jul 13 19:59:57 EDT 2012
       New version: Sun Jul 15 13:57:27 EDT 2012

    Update source: http://snapshots.pfsense.org/FreeBSD_RELENG_8_3/i386/pfSense_HEAD/.updaters

    –-

    Downloading complete but sha256 does not match.
    Auto upgrade aborted.

    Downloaded SHA256: defd1385c42c53b19edf7609a55e4755d843cc24f3578339b9579c486bd2ad59

    Needed SHA256:



  • As for snort I only have those enabled:
    emerging-attack_response.rules
    emerging-botcc.rules
    emerging-compromised.rules
    emerging-deleted.rules
    emerging-dos.rules
    emerging-drop.rules
    emerging-dshield.rules
    emerging-exploit.rules
    emerging-icmp_info.rules
    emerging-inappropriate.rules
    emerging-malware.rules
    emerging-misc.rules
    emerging-netbios.rules
    emerging-rbn-malvertisers.rules
    emerging-rpc.rules
    emerging-scan.rules
    emerging-snmp.rules
    emerging-sql.rules
    emerging-telnet.rules
    emerging-tftp.rules
    emerging-trojan.rules
    emerging-virus.rules
    emerging-web_server.rules
    emerging-worm.rules
    –----------
    snort_attack-responses.rules
    snort_backdoor.rules
    snort_bad-traffic.rules
    snort_blacklist.rules
    snort_botnet-cnc.rules
    snort_ddos.rules
    snort_dos.rules
    snort_scan.rules



  • Current Snort version seems to work mostly fine again (2.5.0). You might want to suppress / disable / tweak the new sensitive data preprocessor. A few versions back there was a issue with whitelists and suppression not working so Snort ended up blocking almost everything.



  • Looks like the culpit was drop.

    Btw, the update still has problems!  I'm unable to update!

    Will try a manual update.



  • Same problem with:
    Current version: 2.1-BETA0
          Built On: Sun Jul 15 13:57:27 EDT 2012
        New version: Mon Jul 16 19:08:20 EDT 2012

    Downloading complete but sha256 does not match.

    Auto upgrade aborted.

    Downloaded SHA256: c51ba9e250fcb26038bd50cea7396cd4515ee4deca9d8f0a26ac2f0cd3620f42

    Needed SHA256:

    Looks like we have ghosts in this forum (no1 fixed this simple but very annoying issue).


  • Rebel Alliance Developer Netgate

    I have VMs that I update every day and I never had a problem.

    However the build process is automated, so it's possible that when the next build was uploaded it "fixed" whatever was being seen on your side.

    If you had a proxy or something else between you and the update server it's possible it had a bad entry cached as well.



  • @Gradius:

    Looks like we have ghosts in this forum (no1 fixed this simple but very annoying issue).

    Well, that includes you. It's an open source project, if something needs fixed that's so simple, why didn't you fix it?



  • New error on last update:
    Auto upgrade aborted.

    Downloaded SHA256: 611ea065d673b639aef41f7d26b4a9187a8b10f3c3d1fc7349f9546fd70e354b
    Needed SHA256: 80e86b04068e10dac248540e1f90b9b7c20f95210fecab17fbf104cec10bfdba

    Current version: 2.1-BETA0
          Built On: Sun Jul 22 13:36:58 EDT 2012
       New version: Tue Jul 24 08:20:58 EDT 2012

    I don't use proxy, just running on a real dedicated machine.



  • Have you checked your memory with memtest86 sounds to me like you might have a bad stick.



  • Crash report begins.  Anonymous machine information:

    i386
    8.3-RELEASE-p3
    FreeBSD 8.3-RELEASE-p3 #1: Fri Aug  3 02:20:02 EDT 2012    root@FreeBSD_8.3_pfSense_2.1.snaps.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_SMP.8

    Crash report details:

    PHP Errors:
    [03-Aug-2012 18:57:47 UTC] PHP Fatal error:  Call to undefined function sync_package_zebedee() in /etc/inc/pkg-utils.inc(457) : eval()'d code on line 1

    Filename: /var/crash/minfree
    2048


Locked