Client OpenVPN connection not using Squid / SquidGuard



  • I have a pfSense 2.0.1 server with OpenVPN and Squid + SquidGuard running. Squid is set up in transparant mode.

    From a remote location a user can succesfull login using OpenVPN. When this user browse the Internet, the connection is not routed through Squid / SquidGuard.

    How can I change the configuration the connection is routed through Squid / SquidGuard in stead off going directly to the WAN?



  • On possibility would be to setup the proxy server address on the clients browser - no matter if squid is running ins transparent mode or not.
    This worked for me in the paste when I tested this.

    The other option could be to set the squid interface IP address as gateway for the openVPN connection in firewall rules. But I am not sure if this will work.


Log in to reply