Installing pfSense 2.0 on Hacom Mars II 1U?



  • Hi,

    I'm trying to install pfSense 2.0 on my Mars II 1U Server (http://www.hacom.net/catalog/mars-ii-pfsense-1u-server).

    It's configured with 4Gb of RAM, and a 8GB DOM for storage.

    I downloaded the image pfSense-memstick-2.0.1-RELEASE-amd64.img, and I wrote it to a USB stick with dd.

    Then I booted it up, and I get the following error message:

    Trying to mount root fro ufs:/dev/ufs/pfSense
    ROOT MOUNT ERROR:
    If you have invalid mount options, reboot, and first try the following from the loader prompt:
    
    set vfs.root.mountfrom.options=rw
    
    and then remove invalid mount options from /etc/fstab.
    
    Loader variables:
    vfs.root.mountfrom=ufs:/dev/ufs/pfSense
    vfs.root.mountfromt.options=ro
    
    Manual root filesystem specification:
        <fstype>:<device>    Mount <device> using filesystem <fstype>
                                                e.g. ufs:/dev/da0s1a
                                                eg. cd9660:/dev/acd0
                                                This is equivalent to: mount -t cd9660 /dev/acd0 /
    
     ?                                           List valid disk boot devices
    <empty line="">                       Abort manual input
    
    mountroot></empty></fstype></device></device></fstype>
    

    I found the troubleshooting guide here:

    http://doc.pfsense.org/index.php/Boot_Troubleshooting

    so I tried going to the loader and typing in the commands:

    set kern.cam.boot_delay=10000
     boot
    

    however, that didn't seem to make any noticeable change, and it still gave me the same error.

    Anh advice on installing pfSense 2.0 on this hardware?

    Cheers,
    Victor



  • What do you get if you type a question mark (to list valid boot devices) at the

    mountroot>

    prompt?



  • heya,

    Turns out it was actually a bad DOM SATA module =(.

    I emailed Hacom, and they said they had a bad batch of 8GB DOM chips…sigh. I wish they'd said that earlier.

    Anyhow, they're sending out a 64GB SDD to replace it =) - I'm using a spare Intel SSD I had lying around until then.

    It was just a bit confusing getting those error messages, and it being linked to a missing HDD - it didn't seem the most intuitive leap...lol. But then, hey, I've probably just been spoilt by Ubuntu and Arch installers...haha.

    Thanks all for your help =).

    Cheers,
    Victor


Log in to reply