Dashboard - XMLRPC communication error: Operation timed out

  • I just noticed yesterday I was having a problem where pfsense can't check for updates to its self or to packages. In the system log I get this error "php: /index.php: XMLRPC communication error: Operation timed out".

    Dashboard says "Unable to check for updates" and the Available Packages list is empty and says "Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity." All computers behind pfsense have no problem accessing www.pfsense.com

    Everything was working probably week and a half ago. Here's my update url, http://updates.pfsense.org/_updaters .

    I did see this thread from not long ago http://forum.pfsense.org/index.php?topic=51229.0 but the resolution the OP found does not work for me as IPv6 is already disabled in my case.

    Any ideas…?


  • What IP address do you get for updates.pfsense.org?

    lee@tc-us-dev01:~$ ping updates.pfsense.org
    PING updates.pfsense.org ( 56(84) bytes of data

  • resolves to

    Not sure if this can have something to do with it but I just a couple days ago setup an ipsec tunnel with this box. Honestly I don't know if this update problem happened before or after this though. I have gone back and disabled ipsec as a test but it still doesn't work.

  • if I run:
    fetch -o - http://www.pfsense.org/packages/pkg_config.8.xml
    like the OP did in the thread I linked to in my first post I see the proper output. So pfsense can get to pfsense.org but for some reason the dashboard and package manager can't?

    The messages I see in the system log have changed a bit:
    php: /pkg_mgr_installed.php: XMLRPC communication error: php_network_getaddresses: getaddrinfo failed: hostname nor servname provided, or not known
    php: /index.php: XMLRPC communication error: php_network_getaddresses: getaddrinfo failed: hostname nor servname provided, or not known

  • Not sure if this is related somehow but I had a problem this morning where all outbound traffic from the lan was being blocked. However pfsense could ping say google.com. I seen this in the system log:

    apinger: /usr/local/bin/rrdtool respawning too fast, waiting 300s.
    apinger: Error while feeding rrdtool: Broken pipe

    I ended up going into Outbound NAT and setting it back to manual and everything started working from that point.

    Not sure if these 2 problems can be related but pfsense still can't check for updates or packages.

  • Ok so this seems to have something to do with me setting up an ipsec tunnel. I have a second pfsense install that I know was able to check for updates. I then setup a tunnel to another location and then noticed it could no longer check for updates. Nothing else has changed. Even if I disable ipsec it can still not check for updates.

    I have another tunnel I need to setup to another pfsense but I don't want to break that one too.

    Any ideas?

Log in to reply