Change in startup script - Fixes many filter reloads from squid.



  • Hello Guys,
    I was starting to wonder why i had some many processes open and why my filter kept getting reloaded. Turns out a script is now wrong for squid.
    In : /usr/local/etc/rc.d/proxy_monitor.sh
    There are 2 lines of these:

    
    NUM_PROCS=`ps auxw | grep "[s]quid -D"|awk '{print $2}'| wc -l | awk '{ print $1 }'`
    
    that needs to change to :
    [code]
    NUM_PROCS=`ps auxw | grep "[s]quid -f"|awk '{print $2}'| wc -l | awk '{ print $1 }'`
    
    The "-D" option is not used and is obsolete. Can one of the devs please review and change the file if necessary?
    I am using :
    2.1-BETA0 (i386) 
    built on Fri Jul 20 01:30:00 EDT 2012 
    With latest squid3.
    
    Thanks,
    Podilarius.[/s][/code][/s]
    


  • Also, with the change, it still starts up 3 times!

    ps axw |grep proxy
    10496  ??  R      0:00.01 sh -c ps axw |grep proxy 2>&1
    10610  ??  IN     0:00.01 /bin/sh /usr/local/etc/rc.d/proxy_monitor.sh start
    10967  ??  R      0:00.00 grep proxy
    14969  ??  IN     0:00.01 /bin/sh /usr/local/etc/rc.d/proxy_monitor.sh start
     4221  v0- I      0:00.02 /bin/sh /usr/local/etc/rc.d/proxy_monitor.sh start
    



Log in to reply