[Resolvido]Erro 111(net::ERR_TUNNEL_CONNECTION_FAILED) +squid+dansguardian+wpad



  • Olá todos !!!

    Estou com seguinte problema ao navegar em paginas https, alguem já passou por esse problema ?
    Toda hora precisa ficar dando control + f5 pra atualizar a pagina.

    Estou usando wpad, bind, dhcp, dansguardian e squid, e sempre dá esse problema, ao navegar as paginas, ja tentei colocar pra navegar somente no squid,
    deu o mesmo problema.

    Se alguem puder me ajudar, obrigadooo.



  • Qual versão de squid você esta usando?

    Tenta instalar o firebug no firefox e veja na aba network do plugin o que esta acontecendo durante a navegação.



  • to usando as seguintes versões

    bind97-9.7.6.1
    dansguardian-2.12.0.0
    squid-3.1.20



  • Já desabilitei o ipv6 que vem habilitado por padrão.  To usando wpad.
    O problema tá no CONNECT HTTPS.
    To pensando aqui como resolver.



  • @cristianonix:

    To pensando aqui como resolver.

    Tenta com o squid 2.

    Não tenho este problema aqui, mas alguns sysadmins reportaram este mesmo problema na 3.1.20

    att,
    Marcello Coutinho



  • Estranho que a versão padrão squid-3.1.19 também teve esse problema….
    Outro problema se eu instalar o squid2, nao vai funcionar forward_for.



  • marcelloc , funcionou com squid 2 o que eu queria.

    Usei o comando abaixo em Custom Options no squid2.

    follow_x_forwarded_for allow all;



  • @cristianonix:

    marcelloc , funcionou com squid 2 o que eu queria.

    Vou testar isso no squid3 assim que tiver tempo…



  • Certo Marcello

    Quero agradecer você, pelo excelente modulo para web do dansguardian.
    Curti demais. Completissimo….



  • @cristianonix:

    Curti demais. Completissimo….

    Obrigado. Deu muito trabalho mesmo  :)

    O último passo que faltou está relacionado ao filtro de ssl, A compilação do código atual gera os certificados mas o browser rejeita.

    att,
    Marcello Coutinho



  • Acabei de ter esse problema agora, quando baixo um download,  e analiso os logs do squid, só aparace TCP_DENIED nos arquivos *.crt
    Ela baixa até um determinado tempo, mas não baixa completo.

    Tem como resolver isso?



  • O problema do ssl que relatei só acontece quando habilita o filtro ssl. Fora isso, o funcionamento é normal.

    No squid2, tive muito problemas de aborted(monitorando via firebug no firefox).


Log in to reply