(Já resolvi) Traffic Shaper: Limiter não funcionando da maneira que esperava



  • Saudações

    Galera, tenho uma internet café com 14 computadores e gostaria de limitar o acesso de alguns IPs.
    O cenário é o seguinte:

    Possuo uma internet da gvt, segundo o speedtest.net, é uma conexão de 6 megas.
    Adquiri recentemente um modem dsl-500b generation ll para testar com o pfSense.
    Nas configurações o modem está em Bridge, o servidor pfSense está discando corretamente no PPPoE.

    O que não estou entendendo é a maneira correta de definir esses limites. Segui esse tutorial
    Youtube Video

    Fiz tudo igual ao video, só mudando a parte em que acrescentei mais IPs para obedecerem aos limites estipulados
    em 800Kbps pra download e 400Kbps para upload.

    **Quando eu utilizo o limite em apenas uma das máquinas listadas nas regras, eu não consigo mais utilizar os outros PCs
    da maneira que eu pretendia.

    O que está parecendo é que o pfSense reservou os mesmos 800Kbps de limite para ambos os IPs das regras.
    Tem alguma maneira de fazer com que cada PC listado utilize cada um uma faixa distinta de limite?**

    –-------------------------------
    Não tinha prestado atenção na hora do Limiter, tava usando todos o mesmo limite, mas era muito evidente isso.
    Criei limite download e upload para cada PC, e agora resolveu.

    Falta de atenção, rs.



  • Cola suas regras para que eu posso analisar?



  • <l7shaper><container></container></l7shaper>
    <dnshaper><queue><name>limiteDownloadMK1</name>
    <number><qlimit><plr><description><bandwidth>800</bandwidth>
    <bandwidthtype>Kb</bandwidthtype>
    <enabled>on</enabled>
    <buckets><mask>none</mask>
    <delay>0</delay></buckets></description></plr></qlimit></number></queue>
    <queue><name>limiteUploadMK1</name>
    <number><qlimit><plr><description><bandwidth>400</bandwidth>
    <bandwidthtype>Kb</bandwidthtype>
    <enabled>on</enabled>
    <buckets><mask>none</mask>
    <delay>0</delay></buckets></description></plr></qlimit></number></queue>

    –-----

    <rule><id><type>pass</type>
    <interface>lan</interface>
    <tag><tagged><max><max-src-nodes><max-src-conn><max-src-states><statetimeout><statetype>keep state</statetype>
    <os><protocol>tcp/udp</protocol>
    <source>

    <address>192.168.1.1</address>

    <destination><any></any></destination>

    <dnpipe>2</dnpipe>
    <pdnpipe>1</pdnpipe></os></statetimeout></max-src-states></max-src-conn></max-src-nodes></max></tagged></tag></id></rule>
    –-----

    Todos os PC estão seguindo o mesmo padrão.

    Bom, claro que minhas contas estão erradas, mas eu não posso deixar os clientes totalmente na mão, o jeito é rezar para que no máximo 5 ou 6 utilizem o limite estipulado para cada um, com net de 6 megas não dá pra fazer milagre, estou estudando aumentar pra 10, quem sabe 20, mas não depende somente de mim, mas vou insistir.</dnshaper>



  • Um conselho que te dou , testa sem o uso de protocolo.
    Só especificando o IP , com destino a qualquer lugar, de qualquer protocolo, saindo da rede lan.
    Bom deverá funcionar.  Senão porque não  testa usando captive portal ?
    Qualquer coisa posta ai.


Log in to reply