Static routes, gateway howto setup?



  • Im trying to setup my first, more complex, home network.

    This is what I am trying to accomplish.

    ISP -> router running dd-wrt with ip-adress 192.168.200.2/30 -> pfsense with ip-adress on WAN/eth0 192.168.200.1/30

    from pfSense I have setup 1 LAN-net 192.168.215.0/24 and 1 DMZ-net 192.168.11.0/24 and pfSense have .254 on both nets.

    From router with dd-wrt I have setup static routes to 192.168.215.0 and 192.168.11.0 with gateway 192.168.200.1.

    The problem I am facing now is that how should I can configure to  get this working on the PfSense (routing, gateway and static route). I have googled and tried several configurations without getting it to work. From pfSense I cannot even ping the router (192.168.200.2) but if I connect a client-computer, instead of the pfSense, I can ping the ip-adress of the router (if I manually set the ip-adress on the client to 192.168.200.1).

    How should I configure on pfSense to get this working?

    Thanks in advance



  • There are two things that I would check first…

    1. Verify that the 192.168.200.2 is set to the default gateway on the routing tab for the wan.
    2. Check your firewall rules for the wan port and allow the ddwrt address to ping your internal systems.

    Out of curiosity, why are you placing your ddwrt between your ISP and your network? Your pfSense is more than likely a faster and better router / firewall. Plus if you move the ddwrt to an internal nic you can play with vlans and have alot of fun!



  • To first answer your curiosity. The server, where pfsense resides, doesn't have a powerful enough UPS to sustain after electrical power failure/loss of electricity - which has happened to me 2 times just this week. And if I am away from home I would like to able to, using WOL, start up the server from the dd-wrt. Other than that the dd-wrt router have more than enough that I need at the moment.

    As of now I can't even ping the pfsense´s WAN-interface from my LAN. pfSense does however respond on its own ping from within pfSense.

    1. I think I have gotten it right…. System-Routing-Gateways. Int: WAN, Gateway: 192.168.200.2
    2. I have now verified that it will answer on ping.



  • Anyone else have an idea how I should proceed?

    I´m kinda stuck right now….  :(



  • as said check the gateway & subnet settings, also make sure you are using the correct physical interface on the pfsense ;)


Log in to reply