Boot Issue



  • After more or less giving up on this (http://forum.pfsense.org/index.php/topic,51645.msg276289.html#msg276289) issue, I tried installing pfSense on an Intel D915GAV with a 64-bit CPU.  At first, I installed the 32-bit version (without thinking) and it appeared to install without a hitch.  On the first boot, however, the sequence got as far as the FreeBSD load menu where one chooses to load normally, without ACPI, in single-user mode, etc., at which point the machine displayed a backslash, the hard drive LED came on continuously, and the computer remained in that state until I CTRL-ALT-DELed, whereupon the process repeated.  Realizing it was probably the version, I then installed the 64-bit version.  This time, the sequence only got as far as the F1 prompt and then did exactly what it had done before: backslash, continuous HD LED, infinite hang.  I should mention that this same machine with no change in hardware had been running FreeBSD 9.0 just fine only minutes before and was running 8.2 prior to 9.0 and before that it was running Windows Server 2008 R2.  Again, I am at a loss.  Any help would be appreciated immensely.



  • Have you tried a pfSense 2.1 snapshot build? pfSense 2.1 snapshots are built on FreeBSD 8.3 which is a more recent release than FreeBSD 9.0.



  • Well, I figured it was worth a try, but no go with the latest snapshot either.  As I said, though, this machine runs FreeBSD 8.2 and 9.0 with no problem.  This time (unlike with the previous motherboard), I do not think it is a hardware issue for that very reason.  The odd thing is that it boots pfSense off of the LiveCD leading up to the installation option (on all versions–not just the latest snap), but after installation refuses to load from the hard drive.  Since the first posting, I've installed on both SATA and PATA drives with exactly the same result.  I'm exasperated because I'd really like to update my firewalls, but I'm afraid to throw any more money at the situation without knowing what is failing and why.



  • Try setting the hard drive in legacy mode.


Log in to reply