[Resolvido] - ASTERISK ATRAS DO PFSENSE ( FALTA AUDIO)



  • Olá a todos

    Estou com um problema no q se refere ao audio voip .

    Tenho um modem em bridge com o  pfsense tratando de autenticar e logo atraz do pfsense o elastix ;

    Consigo registrar normalmente , fiz as alteraçoes no NAt e segue minhas configuraçoes do NAT

    WAN TCP/UDP * * WAN address 5060 (SIP) 192.168.1.100 5060 (SIP) registro

    WAN UDP * * WAN address 5004 (RTP) 192.168.1.100 5004 (RTP) voz

    WAN TCP/UDP * * WAN address 6000 - 20000 192.168.1.100 6000 - 20000 voz

    So q qdo mando a chamada nao escuto nada e ela cai do nada acho q o pfsense da derrubando a conexao .

    tem alguma configuraçao a mais q eskeci de fazer ?

    Um abraço!



  • Bem vindo !!!

    Seguinte libera as portas de 10000 à 20000 (UDP)  -> RTP

    Se você não escuta provalvelmente seja problema de audio.



  • libero no nat normal ?



  • nat normal para esse range de portas.



  • Fiz assim :

    e nao deu certo

    WAN UDP * * WAN address 10000 - 20000 192.168.1.100 - 10000



  • Eu uso aki asterisk atras do pfsen

    tem um esquema que vc tem que fazer no sip_nat.conf

    externhost= <ip externo="" ou="" ddns="">externrefresh=10
    localnet=192.168.60.0/255.255.255.0
    nat=yes

    att

    Souza Linux</ip>



  • WAN TCP/UDP * * WAN address Ports_Voip Voip Ports_Voip

    Criei um aliases com as seguintes portas pro meu asterisk, olha ai.

    Ports_Voip   4569, 5060, 10000:20000, 5070



  • redireciono o ip ou a rede ?



  • Redirecionei para o ip do asterisk.



  • pedromuniz8,

    Além do nat de wan address para o ip do asterisk que o cristianonix postou, é essencial criar o arquivo de configuração de nat do seu elastix como o souzalinux postou.

    Eu prefiro diminuir o range de portas udp para não precisar criar um nat tão abrangente.

    att,
    Marcello Coutinho



  • veirfiquei aki e fiz da seguinte forma

    WAN TCP/UDP * * * 5060 (SIP) 192.168.1.100 5060 (SIP) registro

    WAN UDP * * * 10000 - 20000 192.168.1.100 - 10000

    WAN UDP * * * 5004 (RTP) 192.168.1.100 5004 (RTP)

    mas piorou pq qdo mando a chamada o mesmo da pau mostrando congestion no asterisk

    sao 2 agora

    tenho um telefone ip registrado em 1 servidor no rj

    dai fiz a rota interna para redirecionar as chamadas para o outro q tem o pfsense na ponta mas mesmo assim ta com problema .

    o servidor q tem o elastix nao ta recebendo nada de chamada agora.



  • vi aki no relatorio

    Jul 24 20:56:22 WAN   200.150.158.163:5060   177.135.250.181:5060 UDP

    Jul 24 20:56:23 WAN   200.150.158.163:5060   177.135.250.181:5060 UDP

    Jul 24 20:56:25 WAN   200.150.158.163:5060   177.135.250.181:5060 UDP

    dizendo q esta bloqueando o q pode ser :?

    como faço pra liberar o trafego para este ip ?



  • Seu asterisk fica num linux correto ? É elastix ou algo do tipo ?
    Dependendo da distribuição vem com firewall ativo.
    Verifique isso antes de partir liberando coisas no firewall do pfsense.



  • Pedro,

    Acho que seu nat esta apontando para * e não para wan address.



  • Prezados ,

    Desabilitei estas opçoes :

    Block private networks
    When set, this option blocks traffic from IP addresses that are reserved for private networks as per RFC 1918 (10/8, 172.16/12, 192.168/16) as well as loopback addresses (127/8).  You should generally leave this option turned on, unless your WAN network lies in such a private address space, too.
    Block bogon networks
    When set, this option blocks traffic from IP addresses that are reserved (but not RFC 1918) or not yet assigned by IANA.  Bogons are prefixes that should never appear in the Internet routing table, and obviously should not appear as the source address in any packets you receive.

    e o audio passou isso pode prejudicar ?



  • São proteções do pfsense, mas isso nao deveria influenciar.



  • Funcionou com  essas opções desmarcadas?
    Se funcionou, é porque influencia. Aqui na empresa uso desmarcado mesmo.



  • Funcionou na hr , passou o audio normal qdo desmarquei.

    Obrigado a todos !

    Um abraço!



  • Merece, qualquer dúvida, só postar!!!


Log in to reply