Internal DNS borks when WAN goes down



  • Hi,

    I have this problem whereby if the WAN interface loses connectivity (but is still "up"), then reverse DNS lookups for internal network addresses are really slow, causing problems for me to log into machines remotely using SSH. I don't know what information is relevant to provide, but if someone could assist me in troubleshooting this, I would be grateful.

    Cheers,

    Yax



  • Can you give me some info on your network? Do they use domain controllers with Windows or is it all Linux based? What are the primary and secondary DNS being used?



  • Hi,

    My network is composed principally of linux machines. I have a windows workstation. I am using the pfSense DNS forwarder and then primary and secondary DNS servers provided by my ISP, as well as 8.8.8.8 (third in list).

    Cheers,

    Yax



  • Is the name of your box also provided by DHCP?

    You might want to look at setting that manually, and disable overriding DNS by DHCP


  • LAYER 8 Global Moderator

    So your waiting for dns to timeout on a reverse lookup of your local network address (private space)?  Why don't you just run local dns for your local name space and provide PTR records – this way you will be able to look them up as your suppose to, and won't matter if you have external connectivity or not.



  • Sorry, could you elaborate?

    According to

    By default localhost (127.0.0.1) will be used as the first DNS server where the DNS forwarder is enabled, so system can use the DNS forwarder to perform lookups. Checking this box omits localhost from the list of DNS servers.

    (unchecked)

    What you stated should not be occurring?



  • I have the exact same problem, recently my ADSL went down, and my local DNS started to go really slow and wondered why..

    I have a bridged modem / ADSL what is on my WAN interface.
    I am using the DNS forwarder for local DNS.

    If I manually remove all DNS entries in general settings in pfsense, and I remove the WAN cable, local DNS is fast.

    If there are DNS entries in general settings, and I remove the WAN cable, local DNS is slow.

    I don't understand why this is happening, as 127.0.0.1 is always at the top of the DNS list.

    Why are public domain servers being queried for local domains what are listed in the DNS forwarder? Maybe thats not the problem… ?



  • I have noticed the same. WAN affects the local DNS. I have IP phones with a hostname for the server like: pbx.local. If WANs go down then phones stop to register to the server, which is local.



  • same here …

    maybe some expert can give other direction ?


  • LAYER 8 Global Moderator

    "If there are DNS entries in general settings, and I remove the WAN cable, local DNS is slow."

    Give example of this..  So

    If I query my local dns (pfsense) for a local address.

    
    C:\Windows\System32>dig @192.168.1.253 i5-w7.local.lan
    
    ; <<>> DiG 9.9.1-P3 <<>> @192.168.1.253 i5-w7.local.lan
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49489
    ;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;i5-w7.local.lan.               IN      A
    
    ;; ANSWER SECTION:
    i5-w7.local.lan.        1       IN      A       192.168.1.100
    
    ;; Query time: 5 msec
    ;; SERVER: 192.168.1.253#53(192.168.1.253)
    ;; WHEN: Mon Oct 08 02:02:40 2012
    ;; MSG SIZE  rcvd: 49
    
    

    how is it slow if your wan is down.. So I unplug connection from cable modem - pfsense has NO wan connection, and

    
    C:\Windows\System32>dig @192.168.1.253 i5-w7.local.lan
    
    ; <<>> DiG 9.9.1-P3 <<>> @192.168.1.253 i5-w7.local.lan
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45643
    ;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;i5-w7.local.lan.               IN      A
    
    ;; ANSWER SECTION:
    i5-w7.local.lan.        1       IN      A       192.168.1.100
    
    ;; Query time: 4 msec
    ;; SERVER: 192.168.1.253#53(192.168.1.253)
    ;; WHEN: Mon Oct 08 02:05:09 2012
    ;; MSG SIZE  rcvd: 49
    
    

    so asking for another address

    
    C:\Windows\System32>dig @192.168.1.253 current.local.lan
    
    ; <<>> DiG 9.9.1-P3 <<>> @192.168.1.253 current.local.lan
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15888
    ;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;current.local.lan.             IN      A
    
    ;; ANSWER SECTION:
    current.local.lan.      1       IN      A       192.168.1.220
    
    ;; Query time: 5 msec
    ;; SERVER: 192.168.1.253#53(192.168.1.253)
    ;; WHEN: Mon Oct 08 02:05:49 2012
    ;; MSG SIZE  rcvd: 51
    
    

    This is all with pfsense wan disconnected, except for the first query..  So show example where your slow.


Log in to reply