2 Interfaces WAN PPPoE caem juntas



  • Crie um firewall com o seguinte cenário:

    LAN1
    WAN1_WT (PPPoE) Banda Larga local
    WAN2_ADSL (PPPoE) Oi Velox

    Criei os monitoramento dos gateway em > System > Router > Gateway
    Depois criei o grupo de geteway (Wan1: Tier1 e Wan2: Tier2) em System> Router> Groups
    Depois criei a regra na LAN liberando trafego no grupo de Geteway

    Mas o problema é o seguinte: Quando desplugo a WAN1 a WAN2 cai junto. Não sei o que está acontecendo, pois já fiz esta configuração outras vezes e não deu problemas. A única diferença é que neste cenário as 2 wans são PPPoE.

    Só para esclarecer segue o tutorial que usei como base: http://pontoexe.wordpress.com/2010/11/01/configurando-loadbalance-no-pfsense-2-0/

    Veja abaixo o log (na ordem "os últimos no topo") do meu pfsense quanto desconecto a WAN1:

    Jul 25 13:39:36 php: : The gateway: GROUP1_GTWS is invalid or unknown, not using it.
    Jul 25 13:39:36 php: : MONITOR: WAN2_ADSL is down, removing from routing group
    Jul 25 13:39:36 php: : MONITOR: WAN1_WT is down, removing from routing group
    Jul 25 13:39:36 php: : Gateways status could not be determined, considering all as up/active.
    Jul 25 13:39:32 check_reload_status: Reloading filter
    Jul 25 13:39:31 check_reload_status: Reloading filter
    Jul 25 13:39:22 apinger: ALARM: WAN2_ADSL(208.67.222.222) *** WAN2_ADSLdown ***
    Jul 25 13:39:21 apinger: ALARM: WAN1_WT(8.8.8.8 ) *** WAN1_WESTdown ***
    Jul 25 13:39:17 kernel: re0: link state changed to DOWN



  • Perguntinha boba, mas por acaso as duas interfaces do PFSense não são VLans na mesma placa fisica não neh? Se forem o problema está ai.

    Outra coisa, qual condição você deixou no Groups? Member Down, Hight Latency, etc…?



  • @Valter_Jr:

    Jul 25 13:39:22 apinger: ALARM: WAN2_ADSL(208.67.222.222) *** WAN2_ADSLdown ***
    Jul 25 13:39:21 apinger: ALARM: WAN1_WT(8.8.8.8 ) *** WAN1_WESTdown ***

    Acho que você definiu o ip de teste da wan2_ADSL mas esqueceu de forçar a rota dele pelo link2.
    Em outras palavras: o pfsense acredita que o outro link também caiu porque o ip de teste(208.67.222.222) esta com rota saindo pelo gateway que você desligou.

    att,
    Marcello Coutinho



  • @LFCavalcanti:

    Perguntinha boba, mas por acaso as duas interfaces do PFSense não são VLans na mesma placa fisica não neh? Se forem o problema está ai.

    Outra coisa, qual condição você deixou no Groups? Member Down, Hight Latency, etc…?

    Cavalcanti, está sem VLANs e um link em cada placa de rede fisica separada. Assim

    LAN1: nfe0
    WAN1: re0 pppoe0 (wt)
    WAN2: re1 pppoe1 (velox oi)

    O grupo deixei member down.



  • @marcelloc:

    @Valter_Jr:

    Jul 25 13:39:22 apinger: ALARM: WAN2_ADSL(208.67.222.222) *** WAN2_ADSLdown ***
    Jul 25 13:39:21 apinger: ALARM: WAN1_WT(8.8.8.8 ) *** WAN1_WESTdown ***

    Acho que você definiu o ip de teste da wan2_ADSL mas esqueceu de forçar a rota dele pelo link2.
    Em outras palavras: o pfsense acredita que o outro link também caiu porque o ip de teste(208.67.222.222) esta com rota saindo pelo gateway que você desligou.

    att,
    Marcello Coutinho

    Marcelo, entendi. Mas não sei como fazer isso. se os dois links possuem gateway dinâmicos?

    ???



  • Se eu entendi o que o Marcelloc quis dizer, você precisa determinar que esses dois IPs de verificação vão passar pelo Gateway correto, isso se faz nas regras de Firewall.



  • @Valter_Jr:

    Marcelo, entendi. Mas não sei como fazer isso. se os dois links possuem gateway dinâmicos?

    As três formas que me lembro de cabeça são:

    • rota estatica

    • regra na aba floating

    • definir o gateway de saida de um servidor dns


Log in to reply