Lightsquid reporting - Am stuck, are there lightsquid logs I can look at?



  • Hi folks,

    I assume I've made a mistake, but I'm having trouble getting lightsquid working.  I'm running 2.0.1-RELEASE (i386) built on Mon Dec 12 17:53:52 EST 2011.

    I've installed squid:
    -> Transparent proxy
    -> logging enabled
    -> I double checked that logging is going to "/var/squid/logs"
        (saw a number of posts with probs re logs going to "/var/squid/log"
    -> No custom options set

    I did a directory listing of /var/squid/logs and I can see an "access.log" logfile per day.
    Squid transparent proxy seems to be working great, I can browse away happily.
    The log files grow as time passes…
    ... all seems normal to me.

    I installed lightsquid
      -> Changed the refresh interval to 1 hour (but I've tested with the other intervals too)
    -> I've hit "refresh now" and "refresh full" about a billion times ( ;D OK, maybe a small exaggeration)...

    ...but I only get the odd random day of reporting output.

    After searching on this forum (I've seen issues with the squid logs directory for some users, issues with browser caching for others, and then some corrupt installs)... I tried:
    -> Double checking the squid logs folder
    -> Clearing my browser cache, using different browsers, setting squid not to cache the pfsense box itself
    -> I've done a full reset of the box.  Reloaded all rules from a backup, with the packages removed. Manually added the packages one at a time...
    ... and nothing made any difference.

    I don't see anyone else reporting this problem so I'm assuming I've done something... errr... not clever!  But for the life of me I can't figure out what.

    Are there any lightsquid logs I can look at to see if there are errors when parsing the squid logs?  What do I check next?

    Thanks!



  • Have you tried /var/squid/log ? Just do it (in case you have old GUI sources). Is logging enabled for the proxy server?



  • Yup - logging is enabled.  But nope… I have not tried "/var/squid/log" and I really should have (even to rule it out!)

    I'll try that now and post again.



  • OK - changed to "/var/squid/log" and restarted squid.
    I could see that squid was now generating logs to the new folder (a new access.log generated and grew as I browsed around).

    Then did a refresh now. Then a refresh full.  And nothing changed, the files available in "/var/lightsquid/report" were the same days files that were there before.

    So I switched back to "/var/squid/logs", restarted squid again, etc.. and no difference.



  • @TailWagsTheDog:

    So I switched back to "/var/squid/logs", restarted squid again, etc.. and no difference.

    Did you got the same errors with sarg?



  • Hi marcelloc,

    Sorry for the delay replying - I had never used/installed sarg before so wanted to play with it a bit before commenting.  SARG worked fine as it happens.  I got the realtime reports straight away.  After playing with it a bit I got the scheduled reports too.  I can see plenty of output in /usr/local/sarg-reports.  I'm not 100% sure I understand all the SARG options on the GUI, but I'm sure if I played with it a bit I would get used to it.

    I "could" switch over to using SARG, but if it's possible I'd like to continue using lightsquid.  Does the fact that SARG works tell me anything (other than the fact the SQUID is logging away correctly and that SARG is an option for me now!)??


Log in to reply