2 DSL: Redirecting traffic



  • We have 2 DSL lines and 1 LAN and I would like to redirect traffic of certain users to another DSL. Something like :

    host from 192.168.0.1 to 192.168.0.20 must only use DSL1 as long as it is up. It will only be allowed to use DSL2 if DSL1 is down.
    host from 192.168.0.21 to 192.168.0.40 can use either DSL1 and DSL2
    host from 192.168.0.41 to 192.168.0.60 must only use DSL2 as long as it is up. it will only be allowed to use DSL1 if DSL2 is down.

    How can this be done ?

    Thanks. :-)



  • Other users might do it another way, but I'd look at doing it like this:

    • Create the aliases for the three ranges: 192.168.0.1 to 192.168.0.20; 192.168.0.21 to 192.168.0.40; 192.168.0.41 to 192.168.0.60

    • Setup the two gateways, like in the screenshot: 1o2 = 192.168.0.1 to 192.168.0.20; 1e2 = 192.168.0.21 to 192.168.0.40; 2o1 = 192.168.0.41 to 192.168.0.60

    • Create 3 rules, near the top of your LAN rules (or where appropriate); using the 3 'range' aliases for the source; choosing the appropriate gateways








  • Thank you ! we'll definitely try that. :)



  • we tried several times configuring this but we never saw the hosts using the WAN2 gateway group. It's really getting exasperating setting up our pfsense box.  :-\



  • I didn't mention it, but did you remember to set the correct Gateway Priority for each Gateway Group you set up?



  • @Rezin:

    I didn't mention it, but did you remember to set the correct Gateway Priority for each Gateway Group you set up?

    Yes we did.
    Here's the priority :
    GROUP1
    1st range = priority GATEWAY2 (GATEWAY1 = tier 2 / GATEWAY2 = tier 1)
    GROUP2
    2nd range = both tier 1 (GATEWAY2 = tier 1 / GATEWAY1 = tier 1)
    GROUP3
    3nd range = priority GATEWAY1  (GATEWAY1 = tier 1 / GATEWAY2 = tier 2)

    Thank you very much for the help.



  • I can still see that whenever I check my IP, it is still using WAN1 instead of WAN2. Any comment regarding redirecting traffic please ?



  • Redirection works properly…. if Squid is not running on the same machine.  :-\



  • My mistake, it still doesn't work properly. After pulling off the plug (2nd time) of the of the 1st WAN, pfsense started to loadbalance the connection by switching its connection using two connections even after putting back the the 1st WAN.

    That being said, it rarely used the primary connection now, but rather using the 2nd connection as its primary.



  • I noticed that if I connect to pfsense through squid on another machine, it switches connections (wan1/wan2) as if it is load balancing. but if I connect directly using PFsense, it only uses one connection which is it should be.


Locked