Different versions of same package



  • Hi
    I'll explain my problem with an example.
    Suppose that I've install Squid manually and perl-5.14.2_2 installed depending on Squid.
    I want to install an another package (whatever) and it depends on perl-5.14.4_4.
    An error appears "package 'perl-5.14.4_4' conflicts with perl-5.12.2_2".

    What should I do?
    Is there an option with pkg_add to install both of versions? I've looked at manual of pkg_add but can't informed.

    Thanks.



  • @ardunio:

    Is there an option with pkg_add to install both of versions?

    pkg_add -f



  • @marcelloc:

    @ardunio:

    Is there an option with pkg_add to install both of versions?

    pkg_add -f

    Thanks a lot !
    So, Can it damage packages like overwriting old versions?



  • @ardunio:

    So, Can it damage packages like overwriting old versions?

    Yes it can. In most cases will not but take care, make backups and test on labs first.


  • Rebel Alliance Developer Netgate

    If you install two versions of the same package, they probably will overwrite each others' files. Whichever one you installed last will be the files that are in place.

    It's highly unlikely that you really need two versions of perl installed. Just install the new one, 5.14.x, and things should use it.

    Wouldn't hurt to run "perl-after-ugprade" so it can hunt down libraries in the old perl dirs and move them to the new ones



  • @marcelloc:

    @ardunio:

    So, Can it damage packages like overwriting old versions?

    Yes it can. In most cases will not but take care, make backups and test on labs first.

    Thank you.



  • @jimp:

    If you install two versions of the same package, they probably will overwrite each others' files. Whichever one you installed last will be the files that are in place.

    It's highly unlikely that you really need two versions of perl installed. Just install the new one, 5.14.x, and things should use it.

    Wouldn't hurt to run "perl-after-ugprade" so it can hunt down libraries in the old perl dirs and move them to the new ones

    Hi. perl was example. Clearly, I'm trying to build an iso with squid + guard + freeradius based pfSense 2.0.1. pfSense's php-mysql extension installs mysql-client-5.5.25 and freeradius-2.1.12_1 depending on mysql-client-5.1.63. ( I use your package repo. ) So mysql-client-5.1.63 fails. I use the way that you install bsdinstaller to pfSense.

    But today I've noticed, freeradius-2.1.12_1 originally builded without mysql, openldap etc. I've used it and solved the problem in this way.
    It works but I don't know how sensible :)


Log in to reply