NAT Outbound Source IP problem



  • Hy,

    First of all congrats for the product! Keep up the good work!

    I have a bit of a trouble. I run several servers behind the firewall. To each of the server I have assigned a static public IP nated to the respective LAN IP.

    All works well and smooth but it seems that every external connection, on any service (web, dns, smtp etc) is translated to 192.168.0.1, the pfsense firewall's IP.

    That's inconvenient for me as I am unable to make any reports on traffic, can't sync my secondary DNSs (in another network) with the primary DNS from my current network and so on.

    Anyone got some advice for this particular issue?

    Thanks a lot!

    Cheers!



  • Are you actually using 1:1 NAT ? (Firewall -> NAT -> 1:1)



  • @dhatz:

    Are you actually using 1:1 NAT ? (Firewall -> NAT -> 1:1)

    Not right now, no. I tried that too but still no luck. For now it's just port forward.



  • In that case you'll have to use "Manual Outbound NAT".



  • @dhatz:

    In that case you'll have to use "Manual Outbound NAT".

    Ok. I tried that but didn't quite succeed. What I did was to switch to manual outbound NAT rule generation and set a rule on interface LAN, protocol any, source any, source port - blank, destination any, port - blank, address Interface address, static port - uncheck. So far no changes.

    Any suggestions?



  • Are you actually testing this from outside your network and getting that result?


Log in to reply