Captive portal still doesn't start automatically on system startup



  • I have just installed

    2.1-BETA0 (i386)
    built on Fri Jul 27 15:20:57 EDT 2012
    FreeBSD 8.3-RELEASE-p3

    Captive portal was enabled in the configuration file but wasn't invoked when I attempted Internet access after startup. I went to the Captive Portal configuration web page and clicked on Save without making any changes and next attempt to access internet site invoked Captive Portal login page.

    I looked in /var/log/portalauth.log and the only entries for today were

    Jul 30 07:35:49 pfsense2 logportalauth[48941]: Restarting captive portal().
    Jul 30 07:36:34 pfsense2 logportalauth[7684]: LOGIN: zzz, 00:a1:b0:64:3b:83, 192.168.51.217

    which suggests to me logportalauth wasn't started on system startup.

    The last few entries in /var/log/system.log are

    Jul 30 07:15:30 pfsense2 login: login on ttyv0 as root
    Jul 30 07:15:32 pfsense2 check_reload_status: Reloading filter
    Jul 30 07:35:49 pfsense2 check_reload_status: Syncing firewall
    Jul 30 07:35:51 pfsense2 minicron: (/etc/rc.prunecaptiveportal) terminated by signal 15 (Terminated: 15)
    Jul 30 07:35:56 pfsense2 check_reload_status: Reloading filter

    and the only occurrence of the word portal in the system log seems to correspond to my clicking Save on the portal configuration page:```
    $ clog /var/log/system.log | grep portal
    Jul 30 07:35:51 pfsense2 minicron: (/etc/rc.prunecaptiveportal) terminated by signal 15 (Terminated: 15)
    $

    
    Anything I should look for to help debug this problem?


  • In Captive Portal I have a single zone without a name. Could it be having an identity crisis?  :)



  • I have 1 zone with a name and have the same problem. There is a bug report , I don't think it's been worked on yet.



  • I have a recollection reading in the last month or so, an uncontradicted report that captive portal was now working.





  • Try with snapshots of tomorrow.



  • 2.1-BETA0 (i386)
    built on Wed Aug 1 16:50:44 EDT 2012
    FreeBSD 8.3-RELEASE-p3

    Still has the same problem.



  • @Alan87i:

    2.1-BETA0 (i386)
    built on Wed Aug 1 16:50:44 EDT 2012
    FreeBSD 8.3-RELEASE-p3

    Still has the same problem.

    You have to be more helpful than that.
    Give me output of:
    kldstat
    ipfw_context -l
    ipfw show
    ifconfig
    ps -ax | grep light



  • @ermal:

    @Alan87i:

    2.1-BETA0 (i386)
    built on Wed Aug 1 16:50:44 EDT 2012
    FreeBSD 8.3-RELEASE-p3

    Still has the same problem.

    You have to be more helpful than that.
    Give me output of:
    kldstat
    ipfw_context -l
    ipfw show
    ifconfig
    ps -ax | grep light

    
    [2.1-BETA0][admin@pfsense.testing.com]/root(1): kldstat
    Id Refs Address    Size     Name
     1   10 0xc0400000 13a4b10  kernel
     2    2 0xc2e3f000 12000    ipfw.ko
     3    1 0xc2edf000 e000     dummynet.ko
    
    
    
    [2.1-BETA0][admin@pfsense.testing.com]/root(2): ipfw_context -l
    Currently defined contextes and their members:
    
    
    
    [2.1-BETA0][admin@pfsense.testing.com]/root(3): ipfw show
    ipfw: getsockopt(IP_FW_GET): No such file or directory
    [2.1-BETA0][admin@pfsense.testing.com]/root(4): ifconfig
    rl0: flags=108843 <up,broadcast,running,simplex,multicast,ipfw_filter>metric 0 mtu 1500
            options=3808 <vlan_mtu,wol_ucast,wol_mcast,wol_magic>ether 00:40:f4:84:09:44
            inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
            inet6 fe80::1:1%rl0 prefixlen 64 scopeid 0x2
            nd6 options=1 <performnud>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    rl1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=3808 <vlan_mtu,wol_ucast,wol_mcast,wol_magic>ether 00:e0:7d:f8:ed:fa
            inet6 fe80::2e0:7dff:fef8:edfa%rl1 prefixlen 64 scopeid 0x3
            inet 192.168.0.7 netmask 0xffffff00 broadcast 192.168.0.255
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    plip0: flags=8810 <pointopoint,simplex,multicast>metric 0 mtu 1500
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
            nd6 options=3 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
            syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    enc0: flags=0<> metric 0 mtu 1536
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    ipfw0: flags=8801 <up,simplex,multicast>metric 0 mtu 65536</up,simplex,multicast></promisc></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></pointopoint,simplex,multicast></full-duplex></performnud,accept_rtadv></vlan_mtu,wol_ucast,wol_mcast,wol_magic></up,broadcast,running,simplex,multicast></full-duplex></performnud></vlan_mtu,wol_ucast,wol_mcast,wol_magic></up,broadcast,running,simplex,multicast,ipfw_filter> 
    
    
    [2.1-BETA0][admin@pfsense.testing.com]/root(5): ps -ax | grep light
    31826  ??  S      0:00.08 /usr/local/sbin/lighttpd -f /var/etc/lighty-webConfig
    53082  ??  S      0:00.02 /usr/local/sbin/lighttpd -f /var/etc/lighty-main-Capt
    32871   0  R+     0:00.00 grep light
    
    

    I got all this from shell with putty on a windows box.
    And ran them all after a reboot.



  • I still have the same problem. Whenever I restart the Pfsense, captive portal doesn't work well unless manually restart it. :-[



  • Bug #2529 here still occur. Can somebody report in redmine page the feedback ?.



  • When i create a new captive portal, when select options like bandwith and vouchers, i got this message:

    Aug 13 23:02:38 isg php[9759]: /services_captiveportal_zones.php: New alert found: pfSense is restoring the configuration /cf/conf/backup/config-1344909264.xml
    Aug 13 23:02:40 isg php: : XML error: Undeclared entity error at line 1111 in /conf/config.xml
    Aug 13 23:02:41 isg php: : pfSense is restoring the configuration /cf/conf/backup/config-1344909264.xml
    Aug 13 23:02:41 isg php: : New alert found: pfSense is restoring the configuration /cf/conf/backup/config-1344909264.xml

    Alix board, image from 10 august.


  • Rebel Alliance Developer Netgate

    Make sure you aren't putting a space in the zone name, or any other special characters.

    It would help to see exactly what you're putting in on that page before hitting save that leads to those errors.

    What it's basically saying is that something you entered caused the config to fail the XML parsing test and it was considered invalid.



  • I will get the box and by serial see the configuration. The name was successful created (lowercase, without space and no description).
    Selected enable captive portal interfaces -> wireless.
    disable concurrent logins.
    bandwidth control -> down 2048 up 128.
    Enable username/vouchers.
    Click in save.

    The webconfigurator very slowly wait the response and when this response come, give me the message of restoring config.xml backup.



  • Found the problem.
    The problem was with the language chosen: Portuguese.
    When you click in Save, he change the line:
    <radiusvendor>default</radiusvendor>
    to
    <radiusvendor>padrão</radiusvendor>
    What is a invalid value (this value must continue in english, not portuguese).

    File analysed: /cf/conf/config.xml.bad


  • Rebel Alliance Developer Netgate

    You may want to post in the Portuguese forum about that, since I don't think anyone on this side has actually worked on the translation code.



  • any update?



  • This looked like a fun and easy thing to fix. I was surprised at how easy it is to use the Portuguese interface! There were a couple of places in services_captiveportal.php that got carried away translating conf-file keywords into Portuguese and then attempting to stuff the Portuguese into the config as a keyword.
    Pull request 230 should fix it.



  • I've just completed the most recent update for Mon Sep 24th 2012.

    I have captive portal active on VLAN assigned interface for Wifi users. They can use internet until I click "save" in Captive Portal. There is no Captive Portal page being presented to unauthorized users.

    Jits



  • Mon Sep 24 16:42:11 EDT 2012 certainly has the changes to services_captiveportal.php - it sounds like you at least got the config to save OK.
    You can check in config.xml and look for entries like:

    <radiusvendor>default</radiusvendor>
    
    <radmac_format>default</radmac_format>
    

    These should have values like "default" in English.
    If that happened OK, then need to work out the next thing that is happening. You could try switching to English then setup CP and make sure the config works in English. Then do it again in Portuguese. If a known-good set of options in English breaks it when entered in Portuguese, then go looking in config.xml again for any other setting keywords that have got translated when they should be left as keywords.



  • Thanks for the effort to solve this problem.



  • Still happening in latest build. Anyone have any ideas? Getting frustrated that this is going on so long…



  • I will fix this probably by next week.



  • @ermal:

    I will fix this probably by next week.

    Excellent. Thanks for the intention.



  • Can somebody try this ?.

    Create some script in /usr/local/etc/rc.d like
    ee /usr/local/etc/rc.d/fix_captiveportal.sh

    put this two lines:

    /etc/rc.captiveportal_configure
    /usr/local/sbin/lighttpd -f /var/etc/lighty-visitantes-CaptivePortal-SSL.conf

    Save, do chmod 655  /usr/local/etc/rc.d/fix_captiveportal.sh.
    Reboot.

    OBS: The line /usr/local/sbin/lighttpd -f /var/etc/lighty-visitantes-CaptivePortal-SSL.conf changes on every installation. To see the correct name file, ls /var/etc . Will be something like: lighty--CaptivePortal-SSL.conf (if you use SSL) or lighty--CaptivePortal.conf without SSL.
    In Alix board, patient. 2 minutes (more or less) to everything work. rw on / to write file and chmod take effect.
    This script can be more elaborated and is not the real fix to the problem (can solve temporally i guess).



  • Should be fixed on next snapshots.



  • @ermal:

    Should be fixed on next snapshots.

    I hope it's the one built after: Thu Nov 22 09:33:27 EST 2012??
    In this one it's still not staring as it should :(



  • Its this one https://github.com/bsdperimeter/pfsense/commit/3a4b01476620d33b6d6200849231398f82e593c7
    Probably tomorrow snapshot should have it.



  • I can confirm that this works on the snapshot: "built on Thu Nov 22 14:00:25 EST 2012"
    Have already updated/tested on 5 different routers.

    Thanks so much! :)



  • Working great now on this version:

    2.1-BETA0 (i386) built on Thu Nov 22 13:25:28 EST 2012 FreeBSD 8.3-RELEASE-p4

    (1GB nanobsd i386 on Soekris net5501)

    Thanks for the fix!

    Bruce.


Locked