Dynamic DNS causes Web interface to stop responding for about 2 minutes



  • Hi guys,

    I have been running the latest snapshop of Pfsense lately and one thing I have noticed is the extemely stubborn Web Interface becoming unresponsive when trying to access the Dynamic DNS tab. When trying to log into the test pfsense box today, it wouldn't respond after getting to the home page for about 2 minutes so I left it (This is after a restart). After that thing started to work, but as soon as I tried to access the Dynamic DNS tab, the entire GUI becomes completely unresponsive however the box is still passing traffic as normal.

    I have tried to restart the router but that hasn't worked.

    I have also tried to restart the webconfigurator from the box's interface but that hasn't worked either.

    This isn't the first time this type of problem has happened and this is a fresh install. It's pretty annoying when testing out the new IPv6 features.

    Does anyone know of a remedy?

    Cheers


  • Rebel Alliance Developer Netgate

    Sounds like you don't have working DNS or external routing.

    When you load the page it tries to verify that the IPs on the page match up with what the DNS record should have, which involves making some external connections/DNS requests. If your routing or DNS are broken, the page would take a long time to timeout (~45sec for each DNS query to each DNS server)



  • I have just restarted my external router which is connected to the WAP (Causing me to get a new external IP) and the same problems are happening.

    When loading the main page, the router fails to search for updates and the whole GUI freezes until I restart the whole router however the router is still passing traffic. There is nothing wrong with the DNS as it is the same as it was before the WAN connection was reestablished and equipment on the LAN side can access the internet just fine.

    What on earth could be going on? The only way to unfreeze the router is to restart it as I said. Restarting the Webconfigurator doesn't do anything as when trying to put in the https://[routerip] as normal afterwards, the page doesn't show up. It just keeps loading.

    For some reason the Router seems to be freezing up as soon as I leave it to check for updates on the main page (Which fails for some odd reason since I restarted the external WAN connection).

    Any ideas? This problem is frustrating as there is no way around it and it doesn't make one bit of sense to me.



  • If you just go to a command prompt and run 'killall php' it'll come back to life. Go to Diagnostics>Ping, try to ping google.com. Guessing it won't resolve.


Locked