Processor Interrupt High



  • I'm in the UK with a ~38mbps/10mbps FTTC connection.
    Today I can only get about 1mbps downstream.  Normal diagnostic with the ISP are in progress, but I rebooted my pfsense box and then noticed very high processor interrupts (See attachment) - I'm no freebsd expert - would someone help enlighten me?

    
    $ ifconfig
    em0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=219b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,wol_magic>ether 00:1b:21:b7:7b:93
    	inet6 fe80::21b:21ff:feb7:7b93%em0 prefixlen 64 scopeid 0x1 
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    bge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8009b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,linkstate>ether 00:13:72:d8:a9:38
    	inet6 fe80::213:72ff:fed8:a938%bge0 prefixlen 64 scopeid 0x2 
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    em1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic>ether 00:1b:21:70:14:c8
    	inet6 fe80::21b:21ff:fe70:14c8%em1 prefixlen 64 scopeid 0x3 
    	inet 192.168.10.1 netmask 0xffffff00 broadcast 192.168.10.255
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    	status: active
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    	options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000 
    	inet6 ::1 prefixlen 128 
    	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4 
    	nd6 options=3 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
    	syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    enc0: flags=0<> metric 0 mtu 1536
    em1_vlan110: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:1b:21:70:14:c8
    	inet6 fe80::21b:21ff:feb7:7b93%em1_vlan110 prefixlen 64 scopeid 0x8 
    	inet 192.168.253.1 netmask 0xffffff00 broadcast 192.168.253.255
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    	status: active
    	vlan: 110 parent interface: em1
    em1_vlan103: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:1b:21:70:14:c8
    	inet6 fe80::21b:21ff:feb7:7b93%em1_vlan103 prefixlen 64 scopeid 0x9 
    	inet 192.168.252.1 netmask 0xffffff00 broadcast 192.168.252.255
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    	status: active
    	vlan: 103 parent interface: em1
    pppoe0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
    	inet [!!THIS DATA REMOVED!!] netmask 0xffffffff 
    	inet6 fe80::21b:21ff:feb7:7b93%pppoe0 prefixlen 64 scopeid 0xa 
    	nd6 options=3 <performnud,accept_rtadv>ovpns1: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    	options=80000 <linkstate>inet6 fe80::21b:21ff:feb7:7b93%ovpns1 prefixlen 64 scopeid 0xb 
    	inet 10.0.1.1 --> 10.0.1.2 netmask 0xffffffff 
    	nd6 options=3 <performnud,accept_rtadv>Opened by PID 5990
    ovpns2: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    	options=80000 <linkstate>inet6 fe80::21b:21ff:feb7:7b93%ovpns2 prefixlen 64 scopeid 0xc 
    	inet 10.0.2.1 --> 10.0.2.2 netmask 0xffffffff 
    	nd6 options=3 <performnud,accept_rtadv>Opened by PID 12623
    ovpns4: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    	options=80000 <linkstate>inet6 fe80::21b:21ff:feb7:7b93%ovpns4 prefixlen 64 scopeid 0xd 
    	inet 10.0.4.1 --> 10.0.4.2 netmask 0xffffffff 
    	nd6 options=3 <performnud,accept_rtadv>Opened by PID 21912</performnud,accept_rtadv></linkstate></up,pointopoint,running,multicast></performnud,accept_rtadv></linkstate></up,pointopoint,running,multicast></performnud,accept_rtadv></linkstate></up,pointopoint,running,multicast></performnud,accept_rtadv></up,pointopoint,running,noarp,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></promisc></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,wol_magic></up,broadcast,running,simplex,multicast> 
    
    
    $ vmstat -i
    interrupt                          total       rate
    irq14: ata0                           68          0
    irq16: bge0 em1                   219925         51
    irq20: atapci1                     14286          3
    irq21: uhci0 ehci0                    16          0
    cpu0: timer                      8597332       1999
    irq256: em0:rx 0                  134365         31
    irq257: em0:tx 0                  125812         29
    irq258: em0:link                       2          0
    cpu1: timer                      8597079       1999
    Total                           17688885       4114
    
    
    
    $ top -S
    last pid: 15208;  load averages:  0.00,  0.01,  0.00  up 0+01:12:26    15:16:35
    114 processes: 3 running, 90 sleeping, 21 waiting
    
    Mem: 47M Active, 16M Inact, 50M Wired, 944K Cache, 32M Buf, 868M Free
    Swap: 2048M Total, 2048M Free
    
      PID USERNAME    THR PRI NICE   SIZE    RES STATE   C   TIME   WCPU COMMAND
       11 root          2 171 ki31     0K    16K CPU0    0 141:14 200.00% idle
     6368 root          1  49    0 53596K 20236K piperd  0   0:03  0.20% php
        0 root         10 -68    0     0K    72K -       1   0:44  0.00% kernel
       12 root         21 -60    -     0K   168K WAIT    0   0:21  0.00% intr
     6357 root          1  76    0 54620K 22896K accept  0   0:04  0.00% php
    10548 root          1  64   20  5116K  3916K select  0   0:02  0.00% openvpn
     5621 root          1  76    0 54620K 18860K accept  0   0:02  0.00% php
     5716 root          1  76    0 53596K 17688K accept  0   0:02  0.00% php
     4658 root          1  44    0  7612K  4844K kqread  1   0:01  0.00% lighttpd
    26447 root          1  44    0  4944K  2512K select  0   0:01  0.00% syslogd
    24247 nobody        1  44    0  5556K  2644K select  1   0:01  0.00% dnsmasq
       14 root          1 -16    -     0K     8K -       1   0:01  0.00% yarrow
    23304 root          1  76   20  3656K  1520K wait    0   0:01  0.00% sh
    21237 root          1  44    0  3316K  1356K select  1   0:00  0.00% apinger
        3 root          1  -8    -     0K     8K -       0   0:00  0.00% g_up
        4 root          1  -8    -     0K     8K -       1   0:00  0.00% g_down
    21546 dhcpd         1  44    0  8436K  5444K select  0   0:00  0.00% dhcpd
    27559 root          1  44    0  3316K   924K piperd  1   0:00  0.00% logger
    
    




  • Upgrade to latest stable and a reboot seems to have cured it ;-0


Log in to reply