Altq support for stge and/or fxp



  • Hi,

    I use 1.2-BETA-1-TESTING-SNAPSHOT-05-09-2007 .  I have one asus gigabit network card (stge) and one intel EtherExpress PRO/100 (fxp).

    I didn't make any modifications to pfsense for the intel nic, but for the asus I had to modify loader.conf and copy if_stge.ko from freebsd 6.2 cd to pfsense box /boot/kernel directory according to this man page: http://www.freebsd.org/cgi/man.cgi?query=stge&sektion=4&apropos=0&manpath=FreeBSD+6.2-RELEASE

    Now it works all fine except the traffic shaping support.  When I open traffic shaping wizard I got the following error: "Either your LAN or WAN interface doesn't support ALTQ. The wizard cannot continue"
    According to http://www.freebsd.org/cgi/man.cgi?query=altq both stge and fxp support altq. What could be the problem ?

    Thanks in advance

    ps: I would be really happy if stge support is directly added to pfsense kernel with "device stge" option though I don't know if this is the correct forum for such a request.



  • Hi,

    I solved the problem by editing /etc/inc/interfaces.conf

    The default list of altq supported drivers seems outdated. Since the comment referse to FreeBSD 6.0

     /* Per:
             * http://www.freebsd.org/cgi/man.cgi?query=altq&manpath=FreeBSD+6.0-current&format=html
             * Only the following drivers have ALTQ support
             */
    

    Also stge supports vlan so I add it to vlan supported devices list too.

    Hope this helps someone

    oytun


Log in to reply