Changing keymap



  • Hi.

    On FreeBSD I can change keymap by editing /etc/rc.conf file. But on pfSense, rc.conf is deactivated by developers.
    Is there another way to change permanently?
    Otherwise I'll try to run "kbdcontrol" command at booting time.

    Thanks.



  • It rather a very rare op to do that on a pfSens einstall since you do not spend that much time on the shell.
    Why you want to do that?



  • @ermal:

    It rather a very rare op to do that on a pfSens einstall since you do not spend that much time on the shell.
    Why you want to do that?

    I want to write scripts and edit some files quickly on shell. My keyboard layout is incompatible with FreeBSD's default. I can't put a lot of characters.



  • I do not think pfSense is a development platform rather something to just use.
    Though what works on FreeBSD should work in pfSense too.



  • @ermal:

    I do not think pfSense is a development platform rather something to just use.
    Though what works on FreeBSD should work in pfSense too.

    I didn't say that pfSense is a development platform. pfSense is open to modify and I just wanted to change some files.
    I've wondered something and asked the forum's development section. If I'm wrong, sorry.



  • Just a suggestion, if you are editing text files and not thousands of them, then I find it is easy to use Diagnostics:Edit File. I load the file, ctrl-A, ctrl-C to copy it all, paste it into a favourite editor on a client computer (e.g. on Windows I use Notepad++), save and edit it there, then copy and paste it back into the Diagnostics:Edit File text box and press Save.
    Once I have a current copy in my editor, then there is no need to copy again from pfSense. I can just keep working on it and copy-paste it back to pfSense to test. Doing this means you can use an editor and keyboard and locale environment that suits you for editing.
    But I guess you are using the pfSense box at a real screen and keyboard attached to the box, rather than remotely through the browser and SSH command prompt sessions or a serial console.



  • @phil.davis:

    Just a suggestion, if you are editing text files and not thousands of them, then I find it is easy to use Diagnostics:Edit File. I load the file, ctrl-A, ctrl-C to copy it all, paste it into a favourite editor on a client computer (e.g. on Windows I use Notepad++), save and edit it there, then copy and paste it back into the Diagnostics:Edit File text box and press Save.
    Once I have a current copy in my editor, then there is no need to copy again from pfSense. I can just keep working on it and copy-paste it back to pfSense to test. Doing this means you can use an editor and keyboard and locale environment that suits you for editing.
    But I guess you are using the pfSense box at a real screen and keyboard attached to the box, rather than remotely through the browser and SSH command prompt sessions or a serial console.

    Hi. Thanks for your suggestion. I did this way several times. I edit and test files frequently. Console is most practical for me with ee and vim.


  • Rebel Alliance Developer Netgate

    The kbdmap(1) command is probably what you're after, or maybe kbdcontrol(1)

    Both are in the pfSense image.

    If you find one that works for you, add it to your ~/.profile or somewhere similar.



  • Thanks a lot. I had run  kbdcontrol in rc.bootup. Now trying to add to .profile


  • Rebel Alliance Developer Netgate

    If you get it working, it would be helpful to others if you post the syntax you used for the command and where it ended up working best for you.



  • I use "/usr/sbin/kbdcontrol -l /usr/share/syscons/keymaps/whatever"

    First I added it to "/etc/rc" file before the line that runs rc.bootup script and works. Than removed here and added to rc.bootup file to test and worked. I don't remember which line now. But i think it'll be work when you run it before rc.initial runs.



  • Thanks, the first option worked for me as well.



  • @ardunio:

    I use "/usr/sbin/kbdcontrol -l /usr/share/syscons/keymaps/whatever"

    First I added it to "/etc/rc" file before the line that runs rc.bootup script and works. Than removed here and added to rc.bootup file to test and worked. I don't remember which line now. But i think it'll be work when you run it before rc.initial runs.

    Tyvm !


Locked