More than 1 default gateway



  • Trying to solve a hardware related problem I'm now running the development version instead of 2.01
    I noticed I can select more than 1 default gateway in the webif where this wasn't possible before.

    Is this intended and if so, why wasn't it in 2.01
    How should I read "default gateway" if I select more than one?



  • You cannot select multiple default gateways (for the same protocol at least, you can have a default on v4 and one on v6). That's what gateway groups are for. If there is a way to do that, that's a bug. There are some general gateway issues to be addressed in 2.1, though that's not one I've seen, I'll make sure to test for that.



  • A week ago I had a case where we had 2 ISPs - 1 on WAN and 1 on OPT1. The ISP on WAN was being disconnected, so I wanted to change the default gateway to OPT1. I could select default gateway on OPT1. Then I had both WAN and OPT1 as default gateways. Went into WAN and tried deselecting default gateway then save. The change didn't actually "stick" on the System:Gateways display. I tried a few times then eventually succeeded by some means (can't remember exactly - need to try this again somewhere).
    I guess it's tricky for the code - if I select "default gateway" on one of the gateways, then the code should find the current default gateway and deselect that also.



  • Well, then we have a bug in the webIF
    I'm using the August 5 build and it was there in the August 3.

    I never experienced it in 2.01
    It must have slipped in after implementing ipv6?


Locked