Problemas com o zabbix_proxy



  • Bom dia !!

    Galera, estou com um pfsense 2.0.1 tentando configurar o zabbix_proxy para funcionar com um Zabbix Server 2.0.2, o problema é que já segui os vários tutorias da internet e simplesmente não consigo monitorar nada :(, já liberei as portas nos firewalls(10051 inclusive 10050), gostaria de saber se alguém ja conseguiu rodar o zabbix_proxy do pfsense com o Zabbix Server 2.0.2?? seria possível isto?

    muito obrigado desde ja. :)



  • opa…

    não tenho conhecimento em zabbix, mas talvez este link te ajude

    http://www.pfsense-br.org/blog/page/2/

    abraços...



  • @Kristhian:

    opa…

    não tenho conhecimento em zabbix, mas talvez este link te ajude

    http://www.pfsense-br.org/blog/page/2/

    abraços...

    Kra não achei nada no link que você postou a respeito do assunto que eu perguntei… mas valeu a intenção,

    alguém mais tem alguma ideia?



  • @gpostiglioni:

    Galera, estou com um pfsense 2.0.1 tentando configurar o zabbix_proxy para funcionar com um Zabbix Server 2.0.2,

    Não uso o zabix, mas se me lembro bem, temos outro tópico aqui no fórum que diz que a versão atual do pacote no pfsense é a 1.4 e não a 2.
    Deve ser por isso que você não consegue trafegar as informações.

    att,
    Marcello Coutinho



  • gpostiglioni,

    Utilize o Zabbix Server 1.8.X ou aguarde alguns meses. O pessoal do desenvolvimento do Zabbix está trabalhando para reconstruir o template do pfSense de modo que seja totalmente compatível (pfSense 2.X com Zabbix 2.X).

    Abraços!
    Jack



  • Bom Dia!!

    Amigos, Sucesso!!  Consegui compilar o proxy para o zabbix 2.0.2 substutuí o executavel zabbix_proxy 1.8.8 do Pfsense, pelo que eu compilei (2.0.2), e funcionou!!! Parece que houveram mudanças no banco de dados por isso a versão antiga do proxy não funciona com a versão 2.0.2 do server, o unico inconveniente ainda, como o próprio JackL havia comentado é que o template não funciona, mas fica a dica ai caso alguem precise, ele monitora alguma coisa com o template do freeBSD!!

    A todos que comentaram muito obrigado!!



  • @JackL:

    gpostiglioni,

    Utilize o Zabbix Server 1.8.X ou aguarde alguns meses. O pessoal do desenvolvimento do Zabbix está trabalhando para reconstruir o template do pfSense de modo que seja totalmente compatível (pfSense 2.X com Zabbix 2.X).

    Abraços!
    Jack

    Desculpa a pergunta, mas o "zabbix_proxy" faz a mesma função (ou parecida) que o squid?



  • @gpostiglioni:

    Consegui compilar o proxy para o zabbix 2.0.2 substutuí o executavel zabbix_proxy 1.8.8 do Pfsense.

    Você compilou via ports em um freebsd 8.1?

    Pode postar o procedimento para ajudar(mais ainda) quem precisar atualizar?

    att,
    Marcello Coutinho



  • @elvio.tche:

    Desculpa a pergunta, mas o "zabbix_proxy" faz a mesma função (ou parecida) que o squid?

    Não… O Zabbix Proxy é um recurso da plataforma de monitoramento Zabbix utilizado para consolidar as informações dos hosts monitorados na rede local, de modo a encaminhar uma espécie de resumo dos dados monitorados para o Zabbix Server (evitando a comunicação direta entre Zabbix Agent e Zabbix Server - O que aumenta muito o overhad de pacotes na rede).

    Agente ----> Zabbix Proxy --------> Zabbix Server

    Para saber mais, fique a vontade para baixar e ler os slides de uma palestra antiga que fiz sobre o tema: http://www.jack.eti.br/www/arquivos/palestras/Palestra_Zabbix_OeSCLivre.zip

    Abraços!
    Jack



  • @marcelloc:

    @gpostiglioni:

    Consegui compilar o proxy para o zabbix 2.0.2 substutuí o executavel zabbix_proxy 1.8.8 do Pfsense.

    Você compilou via ports em um freebsd 8.1?

    Pode postar o procedimento para ajudar(mais ainda) quem precisar atualizar?

    att,
    Marcello Coutinho

    Boa tarde!

    Claro marcelloc ta na mão, segue abaixo os procedimentos que eu segui

    Embora o pfsense esteja usando a versão 8.1 do freeBSD compilei em um freeBSD 8.3 e funcionou perfeitamente, assim acredito que nas versões 8.1 do freeBSD o procedimento seja o mesmo, quanto as dependências, instalei todas manualmente, não utilizei o ports, as versões que eu utilizei foram:

    sqlite 3.7.13
    curl-7.27.0
    net-snmp-5.7.1

    baixadas dos sites dos respectivos projetos:

    http://www.sqlite.org/sqlite-autoconf-3071300.tar.gz
    http://curl.haxx.se/download/curl-7.27.0.tar.gz
    http://sourceforge.net/projects/net-snmp/files/net-snmp/5.7.1/net-snmp-5.7.1.tar.gz/download

    para o zabbix utilizei o pacote

    zabbix-2.0.2

    Baixe e descompacte o sqlite, curl e net snmp, então instale-os com os conhecidos ./configure, make e make install após instalá-los descompacte o pacote do zabbix-2.0.2, entre no diretório e rode o ./configure, mas com os seguintes parâmetros:

    ./configure –with-sqlite3 --with-net-snmp --enable-proxy --with-libcurl --sysconfdir=/usr/local/etc/zabbix --enable-ipv6

    ao terminar o ./configure, rode make e em seguida make install, o binário do zabbix_proxy será gerado na localização:

    /usr/local/sbin

    Vá até o Firewall Pfsense e instale o pacote do zabbix_proxy, mas não faça nenhum tipo de configuração, após o pacote ser instalado, logue-se na console e renomeie ou remova o arquivo zabbix_proxy que se encontra no firewall em /usr/local/sbin/, agora basta copiar o executável que você compilou para a localização /usr/local/sbin no firewall pfsense, seguidos estes passo, configure o proxy no Zabbix e no Pfsense, e teremos o nosso zabbix_proxy 2.0.2 funcionando!!

    no caso de por algum motivo não funcionar, dê uma olhada nos  logs do zabbix_proxy que ficam em /var/log/zabbix.

    Bom galera estes foram basicamente os passos que eu segui.

    Espero ter ajudado!!

    Abraço a todos!!



  • @JackL:

    Para saber mais, fique a vontade para baixar e ler os slides de uma palestra antiga que fiz sobre o tema: http://www.jack.eti.br/www/arquivos/palestras/Palestra_Zabbix_OeSCLivre.zip

    Esclarecido!  Valeu.


Locked