Host name lookup failure



  • Hello
    Probably my problem can be solved very easily, but i have not found how to setup pfsense properly.
    Configuration of network is following:
    Ethernet modem (China Unicom) -> Dell PowerEdge T300 with latest pfSense  -> Switch D-link (network of 10 machines) -> router netgear (just for wi-fi)
    Internet settings are following:
    Static IP
    IP 210.32.157.142
    Subnet 255.255.255.255
    Gateway 210.32.157.141
    DNS 210.32.84.3
    I've installed latest version of pfsense on dell poweredge t300, it should work as router and firewall, but problem is that i can't connect it to the internet. When i try to ping any host from console it gives me "Host name lookup failure" and in logs there is "kernel: arpresolve: can't allocate llinfo for 210.32.157.141". So probably i've done something wrong with Gateway or DNS setup. It should be the issue, because when i put netgear router as DHCP server between ethernet modem and pfsense everything works as a charm.
    I will really appreciate if someone will tell me how to configurate pfsense, in order to get incoming internet connection (Static IP). Thank you.



  • The subnet on the WAN is wrong … should be at least 255.255.255.252 me thinks. possibly even 253 or 254 ... but 255 means it can only communicate with itself ...

    This is routing/subnetting 101.



  • Thank you, podilarius!
    You are right! Problem was in the Subner. Correct one is 255.255.255.252.
    Problem solved.


Locked