Package "vhost" never starts



  • Hi,

    Recently I have installed the vhost from the packages available in the pfsense admin page, which is for hosting a simple page to show some updates for users of my router.
    However, not sure if there are some simple tricks I have missed, or actually this package is suffering from some known bugs –- the service "vhost-http" never starts at all.

    Reading the service control page, "vhost-http" is "Stopped".
    When I tried to start it, a message "vhosts-http has been started." appeared on top of that page.............the "Stopped" persisted and the server couldn't be accessed.

    I have tried to restart the server but I had no luck at all. :-\

    Do you have any ideas on this?
    Thanks for your kind attention.

    some bg info that maybe useful:
    -pfsense 2.0.1 x64 nanoBSD
    -Intel Celeron G530



  • Reading from this thread:
    http://forum.pfsense.org/index.php?topic=37305.0;prev_next=next

    It seems the won't-start issue is due to the x64 version.
    Would you suggest a quick fix to it without moving to a x86 pfsense?
    Thank you.

    Update:
    Or this is the cause for what I see now?
    http://redmine.pfsense.org/issues/999

    ….....I am a bit confused with where my vain attempts are rooted.......


Locked