Lightsquid sqstat http error



  • Hi guys.

    Having a problem with the real time proxy reporting on lightsquid.

    It is giving me this error:

    SqStat error Error (1): Cannot get data. Server answered: HTTP/1.0 403 Forbidden [Web config set to http]

    Error (1): Cannot get data. Server answered: HTTP/1.0 301 Moved Permanently [Web config set to HTTPS]

    Help and suggestion appreciated. It was working fine and i changed my webconfig from http to https it broke.

    Not sure how to fix this.

    Anyone?



  • @H2wk:

    Hi guys.

    Having a problem with the real time proxy reporting on lightsquid.

    It is giving me this error:

    SqStat error Error (1): Cannot get data. Server answered: HTTP/1.0 403 Forbidden [Web config set to http]

    Error (1): Cannot get data. Server answered: HTTP/1.0 301 Moved Permanently [Web config set to HTTPS]

    Not sure how to fix this.

    Anyone?

    Hi there,

    Even I am facing the same issue, right from the day, I have installed pfsense and was wondering if anybody could trace the issue and find a possible solution to address it..

    Thank you in advance



  • You have sqstat error with HTTP or with HTTPS ?



  • Sorry about the delayed response…

    Didn't receive a notification email...

    For both settings in the webconfig , HTTP and HTTPS...

    I have noticed thou that during certain hours it seems to work... so currently now as i type this it isn't actice and i get this error:  Error (1): Cannot get data. Server answered: HTTP/1.0 403 Forbidden.

    The webconfig settings are currently HTTP



  • Even if passed time since this topic opened, just to inform you that in my case was the SquidGuard the problem that report did not work well.



  • @Nikos:

    Even if passed time since this topic opened, just to inform you that in my case was the SquidGuard the problem that report did not work well.

    installed pfsense 2.0.3 with lightsquid.

    it has still the same problem/error



  • nobody solve this uh?  :-[



  • well maybe this will be funny, but i have same issue. well i try something click there and here, and its fix. sqstat back show live realtime stat. What i do? Service-> Proxy Server-> General, "Bypass proxy for Private Address Space (RFC 1918) destination "uncheck", and click save. then i try open Status-> Proxy Report-> Proxy State, i see the page now work, fix. Then i back to Service-> Proxy Server-> General, "Bypass proxy for Private Address Space (RFC 1918) destination "check" again, and click save so the proxy configuration back to last conf.. and i check again Status-> Proxy Report-> Proxy State its still work.

    Well its sound wierd, but lets give it try. Good luck. :)



  • I'm having the same issue with sqstat. I tested with both HTTP and HTTPS. Reinstalled the package, reinstalled pfsense…etc.  I'm at a lose. Does any developers have any idea how to solve this.  I have also scoured Google, found some people saying of certain fixes but they don't work either.

    My Setup...
    2.0.3-RELEASE (amd64)
    built on Fri Apr 12 10:27:15 EDT 2013
    FreeBSD 8.1-RELEASE-p13

    packages installed:
    bandwidthd (2.0.1_5 pkg v.0.1)
    dashboard widget: snort (0.3.4 )
    lightsquid (1.8.2 pkg v.2.32)
    pfblocker (1.0.2 )
    snort (2.9.4.6 pkg v. 2.5.9 )
    squid (2.7.9 pkg v.4.3.3)
    squid3 (3.1.20 pkg 2.0.6 )
    squidguard (1.4_4 pkg v.1.9.5 )

    Thanks for any help,

    James





  • The same situation was at https://forum.pfsense.org/index.php?topic=50366.0

    And NOT only "https://www.altsec.com/2013/10/pfsense-http1-0-403-forbidden-proxy-report/" recipe can help you.

    So, you can also receive the same error at next accidents:

    1. when your's Proxy filter SquidGuard blocked web-access for the "Proxy Squid: Realtime stat (sqstat)", for example in such a case, as if you at "Proxy filter SquidGuard: Common Access Control List (Common ACL)" adventitiously set "Default access" [all] to "deny"!

    2. when your's Proxy server Squid (version >= 3) at the tab "Real Time" displays NOTHING, this can be reached when your's parameters for the Proxy server Squid was WRONG and Squid can't serve web-requests from clients (and writes nothing - it's logs EMPTY). For example, it can be when you fill TEXT aliases in the fields for IP addresses.