Lightsquid package Test



  • I already re-install squid an i got the same error with lightsquid

    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading Lightsquid and its dependencies... done.
    Checking for successful package installation... failed!

    Installation aborted.

    any ideas ?



  • I'm getting the same thing and alls I did was shutdown the box temporarily and rebooted and I got this as well….Beginning package installation for Lightsquid...
    9% 19% 30% 41% 51% 62% 73% 83% 94% 100%

    Installing Lightsquid and its dependencies.
    6% 13% 20% 27% 34% 42% 49% 56% 63% 70% 77% 85% 92% 99% 100% 6% 13% 21% 28% 36%
    43% 51% 58% 65% 73% 80% 88% 95% 100%

    Removing package...
    Removing Lightsquid components...

    Beginning package installation for Lightsquid...
    9% 19% 30% 41% 51% 62% 73% 83% 94% 100%

    Installing Lightsquid and its dependencies.
    2% 5% 8% 10% 13% 16% 18% 21% 23% 26% 29% 31% 34% 37% 39% 42% 45% 47% 50% 53% 55
    % 58% 61% 63% 66% 69% 71% 74% 77% 79% 82% 85% 87% 90% 93% 95% 98% 100% 6% 13% 20
    % 27% 34% 42% 49% 56% 63% 70% 77% 85% 92% 99% 100% 6% 13% 21% 28% 36% 43% 51% 58
    % 65% 73% 80% 88% 95% 100%

    I'm on the latest snapshot. I tried re-installing lightsquid and I get this as well.
    Installing Lightsquid and its dependencies.

    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading Lightsquid and its dependencies... done.
    Checking for successful package installation... failed!

    Installation aborted.



  • Lightsquid package updated to 1.7.1_1.
    Need wait update global pkg_config.xml.



  • It works again.

    Great job!!



  • Great !! it's working now



  • Reinstallation-update fix bug already found, but not updated. Near time will be fixed  ::)

    Include files in lightsquid.xml !must have full path!



  • Now works perfect.

    many thanks
    Alfredo



  • pfSense RC1
    Lightsquid 1.7.1

    404 error when trying to view report



  • @Seth:

    pfSense RC1
    Lightsquid 1.7.1

    404 error when trying to view report

    squid transparent?



  • @dvserg:

    squid transparent?

    Yes. Same here. Squid tranparent and also 404 - Not Found
    on /lightsquid/index.cgi



  • @Shackattack:

    @dvserg:

    squid transparent?

    Yes. Same here. Squid tranparent and also 404 - Not Found
    on /lightsquid/index.cgi

    Do you test with non-transparent squid mode? And pls test access from browser as
    'http://youpfsense/lightsquid/index.cgi'
    This different with url from GUI



  • I have tested it with transparent and non-transparent, with both configurations it´s a 404 - index.cgi not found…. and the report is not going on
    Reinstall lightsquid package is not helpful.
    Greetings
    heiko



  • Transparent non-transpart modes fail.  'http://youpfsense/lightsquid/index.cgi' also fails with a 404 error.



  • @Seth:

    Transparent non-transpart modes fail.  'http://youpfsense/lightsquid/index.cgi' also fails with a 404 error.

    • delete package lightsquid
    • go to command prompt and execute 'pkg_delete lightsquid-1.7.1_1' command
    • install lightsquid

    bug exists on deletion package. Will looking for this bug..



  • for me it works, thanks a lot dvserg



  • That did the trick

    Thanks for your help  ;)



  • I am having a problem with this version of lightsquid on the 1.2 release versions (final not the RC's).

    I updated from 1.2RC2 to RC3 and then to 1.2 final and lightsquid quit working. I tried reinstalling the package to no avail.

    I get a 500 internal server error when attempting to access the index.cgi. I tried the command prompt pkg_delete but I get this:

    pkg_delete lightsquid-1.7.1_1

    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt

    if I install it again, I have my old configuration still and all the processed logs are still there, but it still doesn't work right.

    I noticed there is some issue with one of the cgi files being compiled for the older version of perl or something? Is there a fix for 1.2 final for this?



  • I hate to dig this thread up, but I figured it would be better than starting a new one.

    I'm seeing the same behavior as the original poster.  When clicking “LightSquid" under "Proxy Report” The following is displayed:

    LigthSquid diagnostic.
    Error : report folder '/var/lightsquid/report' not contain any valid data! Please run lightparser.pl (and check 'report' folder content)
    Please check config file !
    –------------------------------------------------------------------------------
    Variable value
    $tplpatph /usr/local/www/lightsquid/tpl
    $templatename base
    $langpatph /usr/local/share/lightsquid/lang
    $langname eng
    $reportpath /var/lightsquid/report
    Access to '/var/lightsquid/report' folder yes


    folder content:

    I've enabled logging in the proxy server, as well as "Allow users on interface" check box checked.  I've also tried it with the "Transparent proxy" check box checked as well as unchecked.

    Any help would be appreciated.

    Thanks

    -Marty



  • squid:
    – Enable log option
    -- Set log path as /var/squid/log
    -- use squid 5-10 min (web browsing trough squid)
    lightsquid
    -- click Refresh_now
    -- goto Lightsquid tab



  • Everything's done as you suggested, yet it still gives the exact same message as I posted.  What am I missing?



  • This message man only, what LS not have information in his DB.  For update information to LS db need have enabling squid log and squid must create log file in '/var/squid/log'.
    Can you checking /var/squid/log/access.log file for exists?



  • Access.log exists in /var/squid/log/, however it's empty…shocker right!



  • I don;t know how or why, but it seems to be working perfectly now.  Thanks for the help!

    -Marty



  • @dvserg:

    This message man only, what LS not have information in his DB.  For update information to LS db need have enabling squid log and squid must create log file in '/var/squid/log'.
    Can you checking /var/squid/log/access.log file for exists?

    I'm experiencing the same issue, I've already reinstalled squid and lightsquid and repeat the same process thrice with futile results, /var/squid/log/access.log exists but empty, cache log though is not. I have 2 new pfsense deployment having this same issue but in my previous installations everything is working fine, I have no idea why this is happening, any ideas how to resolve this?

    TIA



  • @jan:

    @dvserg:

    This message man only, what LS not have information in his DB.  For update information to LS db need have enabling squid log and squid must create log file in '/var/squid/log'.
    Can you checking /var/squid/log/access.log file for exists?

    I'm experiencing the same issue, I've already reinstalled squid and lightsquid and repeat the same process thrice with futile results, /var/squid/log/access.log exists but empty, cache log though is not. I have 2 new pfsense deployment having this same issue but in my previous installations everything is working fine, I have no idea why this is happening, any ideas how to resolve this?

    Squid must work some time for not-empty /var/squid/log/access.log
    Also check permissions.



  • Squid has been running for quite sometime now, more than 2 days already. What should be the correct file permission?

    I know it's quite odd, I have a previous install way back and it's working alright but I can't seem to figure out this one.



  • @jan:

    Squid has been running for quite sometime now, more than 2 days already. What should be the correct file permission?

    I know it's quite odd, I have a previous install way back and it's working alright but I can't seem to figure out this one.

    Access.log must have 'proxy' owner
    Also check squid config gui for enable LOG option.



  • @dvserg:

    @jan:

    Squid has been running for quite sometime now, more than 2 days already. What should be the correct file permission?

    I know it's quite odd, I have a previous install way back and it's working alright but I can't seem to figure out this one.

    Access.log must have 'proxy' owner
    Also check squid config gui for enable LOG option.

    As you can see from the output of ls -l below, access.log is owned by proxy and was already rotated however it's an empty file. Log enabled option in squid is also enabled as I've mentioned awhile back.

    LigthSquid diagnostic.
    Error : report folder '/var/lightsquid/report' not contain any valid data! Please run lightparser.pl (and check 'report' folder content)
    Please check config file !
    Variable value
    $tplpatph /usr/local/www/lightsquid/tpl
    $templatename base
    $langpatph /usr/local/share/lightsquid/lang
    $langname eng
    $reportpath /var/lightsquid/report
    Access to '/var/lightsquid/report' folder yes



  • Do yuo click 'full refresh' button on LS gui?



  • @dvserg:

    Do yuo click 'full refresh' button on LS gui?

    Yes I did, I click both Refresh Now and Refresh full to no avail. I have another pfsense deployment yesterday and squid/lightsquid package works just fine, I can't seem to figure out this one though, perhaps a hard drive failure?


Log in to reply