OpenBGPd error in 2.1-BETA0 (i386) built on Fri Aug 24 08:48:52 EDT 2012



  • When accessing the OpenBGPd configuration page I am getting the following error:
    [24-Aug-2012 15:50:53 UTC] PHP Parse error:  syntax error, unexpected '=' in /usr/local/pkg/openbgpd.inc on line 37

    The build I am running is:
    2.1-BETA0 (i386)
    built on Fri Aug 24 08:48:52 EDT 2012
    FreeBSD 8.3-RELEASE-p4


  • Rebel Alliance Developer Netgate

    Apparently I committed a version of that file a step behind what was on the router live as I was testing it. Fix just went in, should be live in about 10 minutes, just reinstall the pkg after a while and it'll be OK.



  • Unfortunately neither reinstall nor remove works for this package.

    When clicking the reinstall package button it gets stuck after:
    Removing OpenBGPD components…
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...

    When clicking the remove package button it gets stuck after:
    Removing package...
    Starting package deletion for openbgpd-4.9.20110612_1-i386...done.
    Removing OpenBGPD components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...


  • Rebel Alliance Developer Netgate

    Run this:

    fetch -o /usr/local/pkg/openbgpd.inc https://raw.github.com/bsdperimeter/pfsense-packages/master/config/openbgpd/openbgpd.inc
    


  • That fixed my issue. Thanks!


Locked