3WAN LoadBalancing - Problem with 24h disconnect



  • Hello everybody,

    I am using pfsense 2.0.1 with Multi-WAN and 3 WAN gateways. I am using three routers in front of my pfsense (to get three different subnets). At midnight the routers disconnect and reconnet the connection. The time between disconnect and reconnet is just one second and this leads to the problem that pfsense is showing the gateway as offline but it isn't.

    This problem occured when I bought an actual router for my third WAN. The disconnect is just one second.
    Some days ago I upgraded the firmware of the other router and now the reconnect is just one second, too, and I have the same problem with the gateways and pfsense.

    I setup a monitor IP - different for each gateway. Any ideas what I can do ?

    Thanks in advance!



  • perhaps try changing the 'frequency probe' from default 1 second to 5-10 seconds. That way it might not 'see' the disconnect and play along nicely.
    If this is something that can be reproduced consistenly on other systems, someone with a clue should investigate this.

    On all my systems i set it to around 5 seconds to avoid gateways flipping over too fast for no good reason.



  • Sounds not so bad for this situation. Will give it a try.



  • Hi heper,

    want to give you some feedback. The solution with pinging every 5 seconds seems to work and fixed the problem.

    Perhaps you can give me some other advice about the "Down" time. If the field is empty this should be 10s (default) as far as I know. That would mean that if there isn't any answer for the two pings every 5s the WAN will go down. I would like to increase this a little bit and set the "Down" timer to lets say 20s so that there could be 3-4 ping without response before the WAN seems to be down.

    Or is this unimportant because I am using "Packet loss or high latency" as trigger lever in Gateway Groups ?

    Thank you for your help :-)



  • i would think that if you set it on packetloss/highlatency that this would be what causes the interface put offline.
    i have not tested this in detail, nor have i looked at the code.

    i don't think it could hurt to move the 'member down' setting a little higher, but i wonder if it'll matter much.

    on pf2.1 Beta0 there is additional comment in the webgui:

    'Down':
    The number of seconds of failed probes before the alarm will fire. Default is 10.
    NOTE: The Frequency Probe interval must be less than the Down time, otherwise the gateway will seem to go down then come up again at the next probe.



  • Thanks. :-)

    Will set the "Down" time to 30s which should be 6 pings a 5s.


Locked