Broken pfsense by installing freeradius2 and how to recover?

  • Hi all,
    i was not able to find any information to help me get on with my problem. Propably because i do not use the correct search terms - so sorry if this is something really easy.

    I currently can not access my pfsense by any means except for going down into the catacombs and using directly connected monitor and keyboard.
    I do not get any ip adress via dhcp anymore and therefor can not reach the webgui.

    My pfsense has
    5xLAN-interfaces (via VLAN on one physical adapter)
    1xLAN-interface (which i used as backup in other cases i malconfigured :)

    Everything was working fine until i decided to check out 802.1X on a newly created interface using my new wlan-APs. Thus i installed freeradius2 and did not really do much except for creating a user and a NAS/client. I think i left the interfaces freeradius binds to as set by default '*'. This might could be the problem as i have a captive portal on one of the interfaces?

    Anyway i suddenly could not reach pfsense anymore.
    As i had no real idea what went wrong i tried to find out how to deinstall freeradius2 from commandline (found pkg_delete) which i did and i also deleted all files and directories which were suggested by the deinstaller (propably not the best idea on reboot pfsense is now complaining about a whole load of files missing).
    Anyway i still can not reach pfsense.

    So what is the best way to continue? I already tried assigning a new interface (hoped this would allow me access on this one interface). Is there any other easy ways of trying to save the whole configuration (i unfortunately have no current backup config :/ ).
    And if not is resetting to factory standard the way to go?

    Thanks in advance,

  • Hi Michael,

    the interface you set on freeradius2 package is not resposible for that. This is a listening interface. It is just listening on packets which arrive there on the port you sopecified - general 1812.
    Your problem is probably somewhere else.

    The config is placed here:


    perhaps some older backup config files you can use. The date will show you which is the actual one.
    If there is no "old" config just use the actual one, edit is with any editor and delete the parts you do not need anymore (in your case freeradius2 package because you deleted the files but not all files which causes errors) and the reinstall pfsense and restore the config.

  • Thanks a lot for the hint regarding the conf/config.xml . I did not know pfsense can be configured with the help of only this file :O and that it is versioned automatically (now i have also found the corresponding backup/restore option in the web interface).
    Had a whole bunch of old config files and after reseting to factory defaults i could again connect to the web-interface and from there (what i really liked) load one of the old configs from which i knew they worked.


Log in to reply