Disabling LRO with LAGG interface



  • I have a DELL R710 with 2 x Intel Dual Port X520 10G cards and 2x Intel ET2 Gigabit Quad Port Cards.
    The server is running 2.0.1-RELEASE (amd64) nanobsd 2g

    Two 10G interfaces LAGG are directly connected to separate redundant switch core for failover.

    The 10G cards ix1..4  seems to have issues when using LRO though only for outgoing traffic for that interface.
    Disabling LRO through web gue only works for normal active interfaces, i.e using the checkbox in the pfsense web gui.
    System-> Advance->Networking->Disable hardware large receive offload

    This however does not work for LAGG interfaces. My LAGG0 interface consists of ix0 and ix1.
    On runtime running
    ifconfig ix0 -lro
    ifconfig ix1 -lro
    resolves the issue.

    For a permanent solution I've tried adding to /etc/sysclt.conf
    dev.ix.0.enable_lro=0
    dev.ix.1.enable_lro=0
    which does not work.

    I know I can just add the previous commands in some script after boot is finished but I'm looking for more elegant way to solve this issue. Preferably a solution that preserved through upgrade like adding options to /boot/loader.conf.local

    Cheers / Thor


  • Rebel Alliance Developer Netgate

    For some reason I'm thinking we fixed that in 2.1, but I may be misremembering it.

    For a boot-time command solution, there is always the shellcmd tag in the config. There is a package out there to add/edit shellcmd parameters that get executed at bootup, and they are stored in the config and would survive upgrades, etc.



  • Thanks I wasn't aware of the shellcmd feature. Perhaps I'll checkout 2.1 as well as the box isn't going into production for the next couple of weeks. Maybe I can keep it free of extra packages with 2.1.

    Cheers / Thor


Locked