IPSec in 2.1 Beta



  • Hi!

    I have two pfSense 2.0 boxes that are properly connected/working over an IPSec tunnel.  I've upgraded one of the boxes to 2.1 beta0 (pfSense-LiveCD-2.1-BETA0-amd64-20120828-1442.iso).  After the upgrade, it seems like the tunnel doesn't want to get established between the 2.1 and 2.0 boxes.  They have the same configs and options set and everything else works fine but the tunnel.

    Before I get too far along, I was wondering if anybody came across this issue and knows of a solution, or if it's a bug.

    Thanks!



  • I did the same with no difficulties. I did rebuild the 2.1 box rather than upgrade it but the IPSec tunnel worked 1st time.  ;D



  • Have you tried comparing files

    /var/etc/racoon.conf
    /var/etc/spd.conf

    before and after the upgrade?


  • Rebel Alliance Developer Netgate

    I've had tunnels from 2.1 to 2.0 and even 2.1 to 1.2.3. It's not a general issue, would need to see some info about the tunnel config, logs, and the comparison of the files dhatz mentioned.



  • jimp, it seems they're referring to some issue due to upgrade process 2.0 -> 2.1, rather than a 2.1 IPsec interoperability issue.


  • Rebel Alliance Developer Netgate

    Right, and the boxes I'm referring to on 2.1 have been upgraded from 2.0.x (and in some cases, 1.2.3), as well as some clean-install 2.1 VMs.

    Not saying it hasn't happened, but I haven't witnessed it personally.



  • Thanks for all the responses.  It's been awhile since I last checked in, but I will have to run some more tests to try to figure out what the deal is.

    Thanks!


Log in to reply