2.0.1-Release: which version of libpcre is required for lighttpd ?



  • Hi,

    In my efforts to fix a Snort upgrade, it appears that I inadvertently deleted the pcre library required by lighttpd, which no longer starts with the following error:

    
    pfsense php: : The command '/usr/local/sbin/lighttpd -f /var/etc/lighty-webConfigurator.conf' returned exit code '1', 
    the output was '/libexec/ld-elf.so.1: Shared object "libpcre.so.0" not found, required by "lighttpd"'
    
    

    I'm hoping that I can use pkg_add to get it back, but there are several versions of libpcre at http://files.pfsense.org/packages/8/All/. Can someone please tell me which version I should grab? I'm running 2.0.1-Release  …no snapshots applied ...i386 version. Thanks much...


  • Rebel Alliance Developer Netgate

    Best option is to use console option 13 to reapply a firmware update to make sure that all needed files are present. It's possible that more than just pcre is missing.


Locked